Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

3. Написать программу, которая вводит массив из N вещественных чисел, а затем заменяет в нём все элементы, превышающие данное число Z, этим числом. Вывести

5-9 класс

на экран полученный массив и количе-ство замен. Протестировать программу на следующих исходных данных:
а) Z=10 Массив: 1,2 2,6 3 -4,5 11 10,2 3,2 87 -15
б) Z=-2 Массив: 0 -3,1 11 -7,9 -2,1 -1,9 4
НА ПАСКАЛЕ

Kocczn 10 мая 2013 г., 1:31:16 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Bespalikova98
10 мая 2013 г., 3:31:20 (10 лет назад)

var i,j,z,n,count:integer;
var a:array[1..1000] of integer;
begin
writeln('Введите Z: ');
readln(z);
writeln('Введите N: ');
readln(n);
writeln('Введите N чисел через пробел: ');
count:=0;
for i:=1 to n do begin
read(j);
if j<=z then a[i]:=j 
else begin a[i]:=z; count:=count+1; end;
end;
writeln('Количество замен: ',count);
write('Полученный массив: ');
for i:=1 to n do write(a[i], ' ');
end.

Ответить

Другие вопросы из категории

чим відрізняється звичайний пошук інформації в

Інтернеті від пошуку при використанні "хитрощів"

Приветик всем!) Пж помогите мне нужно собрать как можно больше информации про игры которые плохо влияют на психику..) я нашла некоторые, но нужно

больше) пж помогите) надо еще написать почему они плохо влияют или привести пример..) Заранее спасибо)

Читайте также

1. Разработать схему алгоритма, который вводит массив из N целых

чисел и выводит на экран этот же массив в прямом и обратном порядке. Протестировать алгоритм на произвольных массивах, состоящих из 1 числа, из 5 чисел, из 10 чисел.

2. Разработать схему алгоритма, который вводит массив из N целых чисел и выводит на экран элементы с чётными номерами. Протестировать алгоритм на произвольных массивах размерностью 5 и 8 элементов.

3. Разработать схему алгоритма, который вводит массив из N целых чисел и выводит на экран элементы с нечётными номерами в обратном порядке. Протестировать алгоритм для следующих исходных данных:

а) 1 3 5 6 8 9

б) -1 4 6 2 4 6 8 6 9

P.S. Убедительная просьба написать решение целиком и до наступления ночи. Я являюсь дилетантом в Паскале, а эти три задачи являются моим домашним заданием по информатике на завтра.



Вы находитесь на странице вопроса "3. Написать программу, которая вводит массив из N вещественных чисел, а затем заменяет в нём все элементы, превышающие данное число Z, этим числом. Вывести", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.