Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Вычисляемая последовательность чисел по формуле: 1\((sqrt(n^2 + 1) + sqrt(n^2 - 1 )) , где n=1,2,3...

10-11 класс

Определить при каком n два соседних числа будут отличаться друг от друга на величину не превосходящую Е.
Вычислить сумму М таких чисел начиная с К-ого.

ййцуке 16 мая 2013 г., 5:43:17 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
VoCaLo
16 мая 2013 г., 8:08:46 (10 лет назад)

var k, m, e, a, b, c: real;
    n: integer;
begin
     readln(e);
     readln(k);
     for n := 1 to 1000 do
     begin
          b := 1/((sqrt(sqr(n) + 1) + sqrt(sqr(n) - 1)));
         if ((a - b > e) and (c <= k)) then
         begin
            m := m + a + b;
            c := c + 1
         end;
         a := b;
     end;
     writeln(a);
end.

Как-то так вроде =)

Ответить

Читайте также

1. В последовательности чисел подсчитать произведение чисел, кратных 3.

2. В последовательности чисел сравнить, что больше сумма положительных или про-изведение отрицательных.
3. В последовательности чисел определить предпоследнее отрицательное число. (При решении введите дополнительную переменную для хранения предпоследнего отрицательного числа).

Составить программу для нахождения наименьшего общего кратного четырех натуральных чисел:по формуле НОК(A,B)=(A*B)/НОД(A*B)

(Определить процедуру, распознающую НОД двух чисел)

Последовательности создаются по следующему правилу: Первая – цифра «1». Каждая из последующих создается такими действиями: в начало записывается цифра

«1», далее дважды подряд записывается предыдущая последовательность. Вот первые последовательности, созданные по этому правилу: (1) 1 (2) 111 (3) 1111111. Сколько раз встречается цифра «1» в седьмой последовательности?

Члены последовательности вычисляются по формуле Fk = Fk-1 + Fk-2.

Чему равен F3, если F7 = 2 и F



Вы находитесь на странице вопроса "Вычисляемая последовательность чисел по формуле: 1\((sqrt(n^2 + 1) + sqrt(n^2 - 1 )) , где n=1,2,3...", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.