Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Напишите программу на языке паскаль, которая генерирует 10 случайных чисел в диапазоне от 1 до 20, выводит эти числа на экран и вычисляет их среднее

5-9 класс

арифметическое.

лопва 02 марта 2015 г., 1:25:57 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Воделлочка
02 марта 2015 г., 2:47:12 (9 лет назад)

var a,i,b:integer;
s:real;
begin
a:=0;
for i:=1 to 10 do begin
b:=random(20)+1;
a+=b;
write(b,' ');
end;
writeln;
s:=a/10;
writeln(s);
end.

Ответить

Другие вопросы из категории

Читайте также

1. Написать программу для определения количества двузначных чисел в диапазоне от А до B, которые при делении на 6 дают остаток 2. 2. Найти сумму

двузначных чисел в диапазоне от А до B, в которых первая цифра ровно в 2 раза больше второй.

1)Составьте программу,которая заполняет массив e[1..11] случайными целыми числами в диапазоне от -15 до 1 и находит количество элементов кратных 5.

2)Составьте программу,которая заполняет массив e[1..8] случайными целыми числами в диапазоне от 1 до 20 и находит сумму элементов с нечётными значениями и количество элементов кратных 3.
3)Составьте программу,которая заполняет массив e[1..14] случайными целыми числами в диапазоне от -10 до 10,затем изменяет знак положительных элементов на противоположный,а отрицательные элементы заменяет на 0.Спасибо.

Составить программу на языке Паскаль

Вывести на экран таблицу соответствия между весом в фунтах и весом в кг для значений от 1 до 20 с шагом 1 фунт (1 фунт=400г)
Пример оформления результата:
1 фунт=0,4 кг
2 фунт=0,8 кг
....
20 фунт=8 кг

написать программу(на ABC pascal), которая находит сумму четных цифр

и произведение нечетных чисел
в диапазоне от 1 до 10.



Вы находитесь на странице вопроса "Напишите программу на языке паскаль, которая генерирует 10 случайных чисел в диапазоне от 1 до 20, выводит эти числа на экран и вычисляет их среднее", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.