Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

введите с клавиатуры два числа N и M (N<M).определите и выведите на экран количество чисел между N и M, котроые являются номерами високосных

10-11 класс

годов.

Nekto7890 26 апр. 2015 г., 15:17:52 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
TwinGo7
26 апр. 2015 г., 17:36:45 (9 лет назад)

#include <iostream>
using std::cout;
using std::cin;
using std::endl;

int main()
{
   int n, m, counter = 0;

   cout << "Enter n: ";
   cin >> n;
   cout << "Enter m: ";
   cin >> m;

   if(n >= m)
   {
      cout << "Invalid value" << endl;
   }
   else
   {
      while(n <= m)
      {
         if(n % 4 == 0)
         {
            counter++;
         }
         n++;
      }
   }

   cout << counter << " value" << (counter != 1 ? "s" : "") << endl;

   cin.get();
   return 0;
}

 

Вывод:

Enter n: 2000

Enter m: 2012

4 values



На Паскале:

program test;
var n, m, counter: integer;

begin
  write('Enter n: ');
  readln(n);
  write('Enter m: ');
  readln(m);
  counter := 0;
  while n <= m do
  begin
    if n mod 4=0 then
      counter := counter + 1;
    n := n + 1;
  end;
writeln(counter, ' values');
readln();
end.

Ответить

Другие вопросы из категории

1. В таблице приведены запросы к поисковому серверу, условно обозначенные буквами от А до Г. Расположите запросы в порядке

возрастания количества страниц, которые найдет поисковый сервер по каждому запросу. Ответ запишите в виде последовательности соответствующих букв.

Дан целочисленный массив из 30 элементов. Элементы массива могут принимать целые значения от 0 до 1000. Напишите программу, которая подсчитывает

количество элементов массива равных макс. среди двухзначных чисел. Если ни одного такого числа нет, нужно вывести сообщение об этом.

Читайте также

Составьте программу для решения следующей задачи. Введите с клавиатуры два числа: N и M. Если оба числа больше 100, то замените каждое из них меньшим и

выведите результаты на экран. Если первое число положительное, а второе отрицательное, то уменьшите их в два раза и выведите результаты. Иначе, найдите и выведите среднее арифметическое этих чисел.

ПОМОГИТЕ ПОЖАЛУЙСТА!!!! Составьте программу для решения следующей задачи. Введите с клавиатуры два числа: N и M. Если оба числа больше 100, то замените

каждое из них меньшим и выведите результаты на экран. Если первое число положительное, а второе отрицательное, то уменьшите их в два раза и выведите результаты. Иначе, найдите и выведите среднее арифметическое этих чисел.

составьте блок-схему и программу для решения следующей задачи. Введите с клавиатуры два числа: к и л. Если они положительны, то замените каждое на квадрат

их суммы и выведите результаты на экран. Если все числа отрицательны, то каждое сделайте равным наименьшему и выведите результаты. Иначе, К приравняйте к 10, а Л - к 15 и выведите результаты

Для пяти произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие результаты. Если первое, второе и пятое числа отрицательны, то

выведите их произведение. Если третье и четвёртое числа больше100, то выведите среднее арифметическое всех пяти чисел. Если выполняются одновременно два перечисленных выше условия, то выведите на экран все пять чисел без изменения. Иначе, выведите третье и пятое числа, увеличив их в два раза.



Вы находитесь на странице вопроса "введите с клавиатуры два числа N и M (N&lt;M).определите и выведите на экран количество чисел между N и M, котроые являются номерами високосных", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.