Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Сделать задачу в Паскале, вот дана система:

10-11 класс

ln|x|, x< -1
sin x, -1≤x<1
cos x, x≥1
Решение у меня есть (не знаю правильное ли), но саму задачу понять вообще не могу, в чем ее смысл...

Mihail011 22 июня 2015 г., 17:07:31 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
POFIGMEN
22 июня 2015 г., 17:46:07 (8 лет назад)

var
x,y:real;
begin
readln(x);
   if x<-1 then
       y:=ln(abs(x));
   if (x>=-1)and(x<1)then
      y:=Sin(x);
   if x>=1 then
     y:=Cos(x);
writeln(y:4:2);
end.

+ 0 -
Alexsandra29
22 июня 2015 г., 19:31:39 (8 лет назад)

Программу . Насколько я понял, нужно ввести x, чтобы получить y. Забыл написать что y=этим трём выражениям

+ 0 -
Машкевич890
22 июня 2015 г., 20:22:18 (8 лет назад)

Комментарий удален

+ 0 -
Шатеночка
22 июня 2015 г., 23:11:04 (8 лет назад)

но увы, я не до конца разобрался в ней

+ 0 -
Яношка
22 июня 2015 г., 23:59:04 (8 лет назад)

Комментарий удален

+ 0 -
Paris1996
23 июня 2015 г., 0:34:33 (8 лет назад)

Комментарий удален

Ответить

Другие вопросы из категории

Дано натуральное число n.

Найти тройки x,
y,
z
таких натуральных чисел, что

Составить программу в Pascal
Документ объемом 111 Мбайт можно передать с одного компьютера на другой двумя способами:

А) Сжать архиватором, передать архив по каналу связи, распаковать
Б) Передать по каналу связи без использования архиватора.
Какой способ быстрее и насколько, если
-средняя скорость передачи данных по каналу связи составляет 436500 бит в секунду,
-объем сжатого архиватором документа равен 45% от исходного
-время требуемое на сжатие документа-20 секунд, на распаковку-3 секунды?

Читайте также

Задача по информатике (Паскаль)

Пожалуйста помогите сделать задание в паскале.







Дана
матрица А(3.3)

1)

помогите пожалуйста нужна программа Паскаль вот задача (При каждом переходе через волшебный мост мужик, имеющий b рублей, удваивает эту сумму за счет

капитала черта (а рублей), стерегущего этот мост, после чего он должен уплатить черту дань в размере с рублей. Процесс этот продолжается до полного разорения одного из участников.Сколько будет совершено переходов моста?). вот блок схема пожалуйста сроочноо

Помогите решить задачу на паскале, очень нужно:

Дана строка, удалить текст находящийся в скобках (вместе со скобками)

Я тут начал делать, вот только с удалением у меня ничего не получается, напишите как можно сделать

Вот как я делал:
program zd;
uses crt;
var s:string; i,l,n,t,y:integer;
begin
clrscr;
writeln('Введите строку');
readln(s);
l:=length(s);
for i:=1 to n do begin
if s[i]='(' then
t:=i; {здесь присваивал номер найденной скобки}
if s[i]=')' then
y:=i; {так же, как и выше}
delete (s,t,i); {у меня получается, что он удаляет с открывающей скобки и всё что находится вправо, а левая часть до скобки остается нетронутой}
end;
writeln('Данный результат =', s);
readln;
end.



Вы находитесь на странице вопроса "Сделать задачу в Паскале, вот дана система:", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.