Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

Пожалуйста, напишите программу для паскаля: для нахождения делителей числа n и их суммы с помощью цикла while

5-9 класс

суперских 27 марта 2016 г., 8:32:57 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Тетрадка13
27 марта 2016 г., 9:25:07 (8 лет назад)

program s;
var d, n, s: integer;
begin
readln(n);
s:=0;
d:=1;
while(d<=n) do
begin
if(n mod d = 0) then
begin
s:=s+d;
writeln(d);
end;
d:=d+1;
end;
writeln(s);
end.

+ 0 -
Nikewolf
27 марта 2016 г., 11:38:41 (8 лет назад)

Можете, если не хватит времени добавлять в комменты

Ответить

Другие вопросы из категории

Подсчитать количество символов а и в

написать программу для Паскаль

Помогите пожалуйста!
1) дано число 94 в неизвестной системы счисления. в какой- то системе счисления оно равно числу 163. определите систему счисления? 2) дано число 126 в

неизвестной системы счисления. в какой- то системе счисления оно равно числу 176. определите систему счисления? 3) дано число 103 в неизвестной системы счисления. в какой- то системе счисления оно равно числу 147. определите систему счисления? ( это все решается уравнениями. помоги как!)

Читайте также

Пожалуйста! Напишите программу для паскаля-

Имеются два числа:
а) вычислите сумму и разность этих чисел, используя два оператора readln.
б) перепишите программу так, чтобы использовался один оператор readln.
в) добавьте комментарии к программе.

1. Напишите программу, которая вводит трехзначное число и разбивает

его на цифры. Например, при вводе числа 123 программа должна
вывести 1, 2, 3.
2. Напишите программу, которая вводит возраст человека (число, не
превосходящее 120) и выводит на экран этот возраст со словом «»год,
«года» , «лет» . например «21 год», «22 года», «15 лет»

Помогите пожалуйста !!!!

1)Напишите программу,которая запрашивает значения двух переменных и выводит их разность.Приглашение к вводу каждого числа произведите в отдельных

строках.Вывод результата сопроводите пояснениями
2)Напишите программу ввода трех величин( А,В,С) на одной строке,рассчитайте и выдайте на экран на отдельной строке значение выражения: (А*В)/3,14 +3С.
3)Напишите программу вычисления длины окружности и площади круга одного и того же заданного радиуса R.
Решать на паскале...Помогите пожалуйста(((

РЕШИТЕ ХОТЬ ЧТО-НИБУДЬ!!!:з 1.Линейные программы Напишите программу на ШАЯ.Вычислите значения следующих выражений: f=t*t/2+t

2.Условный оператор(ветвление)

Нарисуйте блок-схему.Дано два числа.Верно ли, что он равны?

3.Циклы

Напишите программу на Паскале. Выведите на экран табицу умножения на 4 в виде 1+4=4,2+4=8,....9*4=36.

4.Одномерные массивы

Напишите программу на Паскале.Подсчитайте количество максимальных элементов массива А [1..12].

5.Двумерные массивы

Напишите программу на Паскале. создать массив случайны чисел В[1..6,1..6].Все элементы массива, расположенные выше главной диагонали сделать равными О.Вывести исходный и исправленный массивы.



Вы находитесь на странице вопроса "Пожалуйста, напишите программу для паскаля: для нахождения делителей числа n и их суммы с помощью цикла while", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.