Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

ПРОВЕРЬТЕ, ПОЖАЛУЙСТА! МАССИВЫ, ПАСКАЛЬ.

5-9 класс

УСЛОВИЕ: Задать случайным образом 10 элементов массива: целые числа из интервала от -5 до 50. Найти:
1) сумму нечётных элементов;
___________________________________________
Program Massivsumma;
var
a : array[-5..50] of integer;
n : integer;
summa : integer;
begin
randomize;
Write ('n='); Readln (n);
summa:=0;
for n:= 1 to 10 do
begin
write ('введите число'); readln (a[n]);
if a[n] mod 1 = 0 then summa:=summa+(a[n]);
writeln('сумма элементов с нечетными номерами: ',summa);
end;
end.

CVita 02 апр. 2017 г., 9:51:46 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Griha23760
02 апр. 2017 г., 11:07:49 (7 лет назад)

что-то у тебя вообще неправильно написано).держи мой вариант

+ 0 -
KristinaEfr
02 апр. 2017 г., 11:43:25 (7 лет назад)

А зачем -5 начало массива? И не мод 1, а мод 2

Ответить

Читайте также

РЕБЯТ ПОЖАЛУЙСТА ОЧЕНЬ НАДО! ВЗАМЕН МОГУ РЕШИТЬ ВАШУ ЗАДАЧУ! С клавиатуры вводятся стороны треугольника а, b, c. написать программу , которая в

зависимости от введённых сторон определяет какой треугольник ( равносторонний , разносторонний или равнобедренный ). Можно пожалуйста в Паскале))Заранее спасибочи)))

ПОЖАЛУЙСТА, ПОМОГИТЕ, ПАСКАЛЬ, СРОЧНО!

1. Задать случайным образом 13 элементов числового массива – числа от 10 до 50. Удалить из него:
а) 10-ый элемент;
б) минимальный элемент.

2. Из символьного массива, 7 элементов которого заданы с клавиатуры, удалить максимальный элемент.

Помогите, пожалуйста, по Паскалю! 21. В компьютер вводятся два числа. Если первое больше второго, то вычислить их сумму, иначе - произведение.

После этого компьютер должен напечатать текст ЗАДАЧА РЕШЕНА.

22. В компьютер вводятся длины трех отрезков. Компьютер должен ответить на вопрос, правда ли, что пер-вый отрезок не слишком длинен, чтобы образовать с другими двумя отрезками треугольник. Указание: Для этого его длина должна быть меньше суммы длин двух других отрезков. Замечание: Пока не думайте о том, что слишком длинными могут быть второй или третий отрезки. Об этом – задание из 5.5.



Вы находитесь на странице вопроса "ПРОВЕРЬТЕ, ПОЖАЛУЙСТА! МАССИВЫ, ПАСКАЛЬ.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.