Статистика
Всего в нашей базе более 4 327 657 вопросов и 6 445 963 ответов!

Автоматически задаётся массив из 15 элементов. Переставить их в обратном порядке. Паскаль!

5-9 класс

Mashynya 10 июля 2013 г., 16:11:27 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Lsu69
10 июля 2013 г., 18:04:57 (10 лет назад)

var
a : array [1..15] of real;
i : integer;
c : real;
begin
randomize;
for i := 1 to 15 do
begin
a[i] := random (100);
write (a[i], ' ');
end;
writeln;
for i := 1 to 7 do
begin
c := a[i];
a[i] := a[15 - i + 1];
a[15 - i + 1] := c;
end;
for i := 1 to 15 do
write (a[i], ' ');
readln;
end.

Ответить

Другие вопросы из категории

0,4Мбайт сколько будет бит
Проходим Basic

нам задали написать программу которая изображает палитру цветов.


Читайте также

1 Задание:сформируйте и выведите на экран массив из девяти элементов,каждые три последовательных элемента которого составлены по следующему правилу:

1-й равен значению текущего индекса, увеличенному на 3; 2-й равен квадрату предыдущего индекса; 3-й равен сумме двух предыдущих элементов. 2 Задание : сформируйте массив, содержащий 15 элементов ,с помощью датчику случайных чисел. Получите новый массив,каждый элемент которого равен сумме соответствующего элемента исходного массива и его индекса. В полученном массиве удвойте элементы,которые меньше заданного с клавиатуры числа А,и найдите их сумму . Выведите на экран исходные и полученные результаты .

1). Дан массив из n элементов (n >= 4). Подсчитать среднюю арифметическую второго и предпоследнего элемента массива.

2). Дан массив из n элементов. Написать программу подсчитывающую произведение элементов массива.

решить через паскаль через массивы)) 1.Дан одномерный массив из 10 элементов. Заменить все большие 7 члены массива числом 7. Найти количество

таких членов.

2.Дан массив из 10 элементов. Найти количество элементов с четными индексами.

3.Дан массив из 10 элементов. Найти наибольший элемент массива.

1) Дан одномерный массив из 12 элементов. Составить программу заполняющую массив целыми числами в интервале -20 до 15 2)Требуется

подсчитать кол-во пятерок , четверок, тоек полученных за контрольную работу, если число учеников равно 8

3)Дан одномерный числовой массив,изменить знак элементов массива К[1;12] на противоположный

cформировать одномерный массив из 15 элементов с помощью случайных чисел, получить новый массив каждый элемент, которого равен кубу соответствующего

элемента исходного массива, в полученном массиве вывести элементы стоящие на нечетных местах. Напишите, пожалуйста программу на языке Pascal



Вы находитесь на странице вопроса "Автоматически задаётся массив из 15 элементов. Переставить их в обратном порядке. Паскаль!", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.