Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Каково будет значение переменной Х после выполнения операций присваивания: А:=8 В:=10 Х:=А2+В*A-A

10-11 класс

Valerasandutsa 12 февр. 2015 г., 16:47:02 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Ananas322
12 февр. 2015 г., 18:40:25 (9 лет назад)

наверное так Х=16+80-8
Х=88

Ответить

Другие вопросы из категории

На фабрике по производству микросхем четыре техника (A, B, C и D) производят три продукта (продукты 1, 2 и 3). Производитель микросхем может продать в

этом месяце 80 единиц продукта 1, 50 единиц продукта 2 и, самое большее, 50 единиц продукта 3. Техник A может производить только продукты 1 и 3. Техник B может производить только продукты 1 и 2. Техник C может производить только продукт 3. Техник D может производить только продукт 2. Каждая произведенная единица продукта дает следующую прибыль: продукт 1: 6 руб.; продукт 2: 7 руб.; продукт 3: 10 руб. Время (в часах), требуемое каждому из техников для производства продукта, показано в таблице 16
Время производства продукта

Каждый техник может работать до 120 часов в месяц. Как производитель микросхем может добиться максимальной ежемесячной прибыли?
хотя бы наведетите на мысль.

Второй номер

Помогите решить ребята

Составить программу( записи) :три группы учащихся сажали деревья в школьном саду 4 дней. Выяснить какая группа учащихся во второй день посадила меньше

всех деревьев. Определить группы учащихся посадили в третий день более 12 деревьев. Определить суммарное кол-во деревьев за 4 дня , которое посадила первая группа учащихся

Читайте также

1 .Электронный почтовый ящик имеет объем 1 Мбайт. Информация на его адрес по открытому на прием каналу связи передается со скоростью 128 Кбайт/ мин.

Через какое время у поставщика услуг электронной почты появится повод прислать извещение о переполнении почтового ящика?

2.В мешке лежит 256 красных яблок.
Сколько информации содержит сообщение, что достали красное яблоко
(Объясните Ваш ответ)

3. Каково будет значение переменной X после выполнения операций присваивания?

X=2
Y=4
Y=X*X+X
X=Y*Y-X*X
Заранее спасибо=)

1)Определите значение переменной c после выполнения следующего фрагмента программы:

a :=40 ;
b := 10;
a := - a / 2*b,;
if a > b then
c := b - a
else c := a - 2 * b

2)Определите значение переменной c после выполнения следующего фрагмента программы:
a := 5;
a := a + 6;
b := - a;
c := a - 2 * b

Помогите с тестами по информатике!!! А1. Определите значение целочисленных переменных a и b после выполнения фрагмента программы:

a := 3 + 3*4;

b := (a div 10) + 4;

a := (b mod 10) + 2;

b:= a + b;

a:= a mod 2 + b div 3;

1) a=4, b=14;

2) a= 24, b= 6;

3) a=5, b=12;

4) a=8, b=12.

А2. Для какого из указанных значений числа X истинно высказывание

((X < 5)→(X < 3)) Ù ((X < 2)→(X < 1))

1) 1

2) 2

3) 3

4) 4

А3. Укажите, какое логическое выражение равносильно выражению ¬(A Ú ¬B Ú C) ?

1) ¬A Ú B Ú ¬C

2) A Ù ¬B Ù C

3) ¬A Ú ¬B Ú ¬C

4) ¬A Ù B Ù ¬C

X

Y

Z

F

1

1

1

1

1

1

0

1

1

0

1

1

А4. Символом F обозначено одно из указанных ниже логических выражений от трех аргументов: X, Y, Z. Дан фрагмент таблицы истинности выражения F (см. таблицу справа).

Какое выражение соответствует F?

1) X Ú ¬Y Ú Z

2) X Ù Y Ù Z

3) X Ù Y Ù ¬Z

4) ¬X Ú Y Ú ¬Z

А5. Что будет выведено на печать в результате выполнения следующих операторов:

a := 5; b := 10;

write( 'сумма двух чисел ' ); write( 'a+b' );

write( ' = ', a+b );

1) сумма двух чисел 5+10 = 15

2) сумма двух чисел a+b = 15

3) сумма двух чисел 5+10 = a+b

4) сумма двух чисел a+b = 5+10

5) ни один из ответов 1-4 не верен

А6. Чему было равно значение переменной a, если после выполнения операций

b := sqrt( sqr(a+1) );

c := -b;

a := 1 + 2 / (c-b);

она стала равна 0 ?

1) 2

2) 0

3) –1

4) любое вещ. число, не равное -1

5) ни один из ответов 1-4 не верен

А7. Чему будет равно значение А после выполнения цикла

а:=1024;

While a>0 do

a:=a / 2;

1) 0

2) 1

3) зациклится

4) 512

5) ни один из ответов 1-4 не верен

A8. Сколько раз выполнится тело цикла?

A:=32;

While A>2 do

Begin A:=A / 2; writeln(‘A’); end;

1) 8

2) 6

3) 5

4) 4

5) 3



Вы находитесь на странице вопроса "Каково будет значение переменной Х после выполнения операций присваивания: А:=8 В:=10 Х:=А2+В*A-A", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.