Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Ребят, очень нужна ваша помощь, помогите, объясните как что делать, завтра экзамен((

5-9 класс

Mrmaksimgudz 17 авг. 2015 г., 5:44:51 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
ученицаааааааа
17 авг. 2015 г., 6:24:01 (8 лет назад)

Не знаю как на питоне но на с++ вот:
#include
#include

using namespace std

long long p = 1;
int x

int main() {
while (true) {
cin >> x;
if (x == 0)
break;
if (x % 6 == 0)
p *= x;
}

cout << p;
return 0;
}

Ток учти что даже в лонг лонг может не уместится и возможно у меня в коде грамматические ошибки

+ 0 -
Maria123456788
17 авг. 2015 г., 7:24:18 (8 лет назад)

C++:
#include <iostream>

int main()
 {
   unsigned long long int p = 1LL;
   int n;
   do
     {
       std::cout <<"Number = ";
       std::cin >>n;
       if (n%6==0 && n!=0)
        {
          p*=n;
        } 
     }
   while (n!=0);
   std::cout <<"Proizvedenie: " <<p <<std::endl;
   return 0;
 }

Pascal:
var p:longint;
     n:integer;
begin
  p:=1;
  repeat
    write ('Number = ');
    readln (n);
    if (n<>0) and (n mod 6 = 0) then p:=p*n;
  until n=0;
  writeln ('Произведение: ',p);
  readln;
end.

Ответить

Другие вопросы из категории

ПОМОГИТЕ!!!!!! Текстовый документ, состоящий из 1026048 символов, хранился в 8-битной кодировке КОИ-8. Этот документ был преобразован в 16-битную

кодировку Unicode. Укажите, какое дополнительное количество Кбайт потребуется для хранения документа. В ответе запишите только число.

помогите пожалуйстаа!

во такое заданеи в некотором каталоге хранился файл днепр. jpg.
в этом каталоге создали подкаталог с именем Реки и переместили вышеуказанный файл файл туда, после чего имя файла стало С: ГЕОГРАФИЯ/ФОТО/РЕКИ/ днепр.jpg. Каково полное названиее каталога в котором хранился файл до перемещение?

Один из видов компьютерного меню

Читайте также

Ребят,помогите пожалуйста,щедро вознагражу баллами.Очень нужна ваша помощь,нужно сделать сегодня.Таблица перелетов из Москвы в разные города.

Вопросы: 1. В какое количество городов можно долететь менее чем за 4 часа? Ответ записать в ячейку H2 таблицы. 2. Какой процент от всех 5-часовых перелетов составляют 5-часовые перелеты в Египет? Ответ на этот вопрос нужно записать в ячейку H3 таблицы с точностью одного знака после запятой

1.Постройте блок-схему алгоритма, записанного на алгоритмическом языке:

Напиток
алг
нач
орехи истолочь в ступке
орехи растворить в горячем молоке
варить 10 минут, добавить сахар
охладить
кон
2.Составьте блок-схему нахождения периметра треугольника
по формуле: P=a+b+c, если a=3; b=4;c=5.
3.Даны числа X,Y,Z. найдите их среднее арифметическое.
4. составьте блок-схему вычисления следующего выражения:
a=|x-y| : 10x+|xy+x+y|
РЕБЯТ ПОМОГИТЕ ПОЖАЛУЙСТА ОЧЕНЬ НУЖНА ВАША ПОМОЩЬ!

ОЧЕНЬ НУЖНА ВАША ПОМОЩЬ! Решите задачи.

1.В кодировке КОИ-8 каждый символ кодируется одним байтом. Определите кол-во символов в сообщении, если информационный объем сообщения в этой кодировке равен 160 бит.
1) 10; 2) 16; 3) 20; 4)160.
2.Реферат учащегося по истории имеет объем 110 Кбайт. Каждая его страница содержит 40 строк по 64 символа. При этом в кодировке один символ кодируется 16 битами. Сколько страниц в реферате?
1)25; 2)18; 3)20; 4)22.
3.Автоматическое устройство осуществило перекодировку информационного сообщения на русском языке, первоначально записанного в 16-битном коде Unicode, в 8-битную кодировку КОИ-8. При этом информационное сообщение уменьшилось на 160 бит. Какова длина сообщения в символах?
1)2; 2)18; 3)20; 4)22.

помогите плиз очень нужно:превратите одно слово в другое всякий раз заменяя по одной букве так,чтобы новое слово было существительным в именительном падеже

.
а)ночь-?-?-?-?-?-день
б)рота-?-?-?-?-?-полк
в)бант-?-?-?-?-?-коса
г)бег-?-?-?-?-?-?-?-шаг
д)море-?-?-?-?-?-?-суша
е)миг-?-?-?-?-?-?-?-век
помогите очень нужно,учительница ужасно строгая ненавидит меня помогите!

Пожалуйста помогите создать какую нибудь полезную программу на паскаль , срочно нужно до понедельника, чтобы в этой программе были все темы за 8 класс,

read.writeln.else.to.if и тд которые сможете
Вот пример идеи для программы, в академию поступают какое то количество учеников, нужно написать сколько учеников сдали документы, сколько пришли на экзамен, и сколько учеников кто прошло и не прошло
возможно не возможно создать программу на этой идее, тогда прделагайте свои со своими программами , пожалуйста помогите!



Вы находитесь на странице вопроса "Ребят, очень нужна ваша помощь, помогите, объясните как что делать, завтра экзамен((", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.