Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

По числу текущего месяца определить день недели, если первый день месяца был вторник.(Паскаль)

10-11 класс

ТётяSprite 23 нояб. 2016 г., 22:32:12 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Angirel
23 нояб. 2016 г., 23:23:47 (7 лет назад)

var a:integer;
begin
write('введите число месяца ');
readln(a);
if (a mod 7 = 1) then write('вт');
if (a mod 7 = 2) then write('ср');
if (a mod 7 = 3) then write('чт');
if (a mod 7 = 4) then write('пт');
if (a mod 7 = 5) then write('сб');
if (a mod 7 = 6) then write('вс');
if (a mod 7 = 0) then write('пн');
end.

Ответить

Другие вопросы из категории

властивисть компютера
Написать алгоритм перевода чисел из 10тичной системы счисления в любую другую (от 2ичной до 36ричной) и обратно Вся прогамма не нужна,

только две функции

Желательно на С#, но можно и на других языках

Хотелось бы увидеть красивый и логичный код с красиво назваными переменными и без костылей

Могу и сама но некогда этим заниматься

Читайте также

По заданному числу n от 1 до 365 определите, на какое число какого месяца приходится день невисокосного года с номером n. Программа получает на вход

целое число n и должна вывести два числа: число месяца (от 1 до 31) и номер месяца (от 1 до 12), на которое приходится данный день.

Леголас хочет поразить из лука максимальное количество из десяти мишеней, обозначенных цифрами от 0 до 9. При этом он не хочет, чтобы сумма номеров

двух пораженных подряд мишеней составляла несчастливое для эльфов число 6 или более. Какую по номеру мишень Леголас может поразить последней, если первая его стрела полетела в мишень с номером 0?

написать функцию,сравнивающую две даты.функция должна возвращать(-1) если первая дата меньше второй ,0- если первая и вторая даты одинаковы и 1

-если первая дата больше второй.паскаль.тема записи
в чем ошибка??
type date = record day: 1..31; month: 1..12; year: integer ; end;
var a: date := (day: 1; month: 4; year: 2015); b: date := (day: 1; month: 4; year: 2014); c:integer;

procedure OutDate(d: date);begin with d do writeln(day, '.', month, '.', year);end;
function Srawn(x, y: date): -1..1;beginif x.year > y.year then writeln( 1) else writeln(-1) ; if x.year = y.year then if x.month > y.month then writeln(1) else writeln(-1); if x.year = y.year then if x.month = y.month then if x.day > y.day then writeln(1) else writeln(-1); if x.year = y.year then if x.month = y.month then if x.day = y.day then writeln(0); end; begin OutDate(a); OutDate(b); c:=srawn(a,b); writeln('otwet:', c);end.

иЗ ЧИСЛА И МЕСЯЦА сВОЕГО РОЖДЕНИЯ СОСТАВЬТЕ ТРЕХЗНАЧНОЕ ЧИСЛО СЛЕДУЮЩИМ ОБРАЗОМ:ЕСЛИ ДЕНЬ В ДАТЕ РОЖДЕНИЯ-ЧИСЛО ОТ 1 ДО 9,ТО К ЦИФРЕ ИЗ ОБОЗНАЧЕНИЯ ДНЯ

ПРИПИШИТЕ ДВЕ ЦИФРЫ МЕСЯЦА(НАПРИМЕР,ДЛЯ ДАТЫ 02.03.93 ИСКОМОЕ ЧИСЛО 203)ЕСЛИ ДЕНЬ В ДАТЕ РОЖДЕНИЯ-ЧИСЛО ОТ 10 ДО 31,ТО К ДВУМ ЦИФРАМ ИЗ ОБОЗНАЧЕНИЯ ДНЯ ПРИПИШИТЕ ВТОРУЮ ЦИФРУ ИЗ ОБОЗНАЧЕНИЯ МЕСЯЦА(НАПРИМЕР,ДЛЯ ДАТЫ 23.11.93 ИСКОМОЕ ЧИСЛО 231) мОЯ ДАТА РОЖДЕНИЯ 30.05.95



Вы находитесь на странице вопроса "По числу текущего месяца определить день недели, если первый день месяца был вторник.(Паскаль)", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.