Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Автоморфные числа

5-9 класс

Натуральное число называется автоморфным

Кирилл0101 08 мая 2013 г., 13:49:53 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Lolita100
08 мая 2013 г., 15:40:31 (10 лет назад)

var a, b, a1, i, k, x, q:integer;
begin
readln(a, b);
a1:=a;
k:=0;
while a<>0 do
begin
a:=a div 10;
k:=k+1;
end;
x:=1;
for i:=1 to k do
x:=x*10;
q:=-1;
for i:=a1 to b do
if i=((i*i) mod x) then
begin
write(i, ' ');
q:=i;
end;
if q=-1 then write(q);
end.

+ 0 -
Dosaliiev62
08 мая 2013 г., 17:00:31 (10 лет назад)

какой язык программирования?

+ 0 -
Aleksandra5613
08 мая 2013 г., 18:26:33 (10 лет назад)

Pascal ABC

Ответить

Другие вопросы из категории

Что не является свойством информации?

а) актуальность
б) полнота
в) полезность
г) вирутальность

Написать программу для решения задач(Паскаль):

1)Вычислите значения выражения  \frac{b+ \sqrt{ b^{2}+4ac} }{2a} +IbI
2)Насти среднее арифметическое четырех чисел.

Покажите, что приведённая программа не всегда верно определяет максимальное из трёх чисел, записанных в переменные a,b, c.

если a>b то M:=a if a>b then M:=a;
иначе M:=b всё else M:=b;
если c>b то M:=c if c>b then M:=c
иначе M:=b всё else M:=b;
Приведите контрпример т.е. значения переменных при котором в переменной М будет получен неверный ответ. Как нужно доработать программу чтобы она всегда работала правильно?

Читайте также

Автоморфные числа. Натуральное число называется автоморфным, если оно равно последним цифрам его квадрата. Например: 25^2=625. Напишите программу, которая

вводит натуральное число N и выводит на экран все автоморфные числа, не превосходящие N.

напишите программу которая в последовательности натуральных чисел определяет минимальное число кратное 3. знаю как написать программу

для максимального числа

var

a:integer;

b:longint;

begin

b:=0;

readln(a);

while (a<>0) do

begin

if ((a mod 3=0) and (a>b)) then

b:=a;

readln(a);

end;

writeln(b);

readln

end.

как для минимального??

С клавиатуры вводятся два натуральных числа N и K (0<N<=K<=200000). Требуется написать программу, которая находит сумму простых чисел,

расположенных между N и K(включая эти числа).
Пример входных данных: 2 5
Пример выходных данных: 10

Помогите по программе paskal : 1.дано целое число.напишите программу которая уменьшает на 2 модуль этого числа и выводит на экран монитора

результат

2.дано целое число.напишите,программу которая выводит на экран последнюю цифру данного числа,затем возводит ее в квадрат и выводит на экран монитора результат



Вы находитесь на странице вопроса "Автоморфные числа", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.