Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

ПОМОГИТЕ ПОЖАЛУЙСТА! ОЧЕНЬ НУЖНО!( 1)Осуществите циклический сдвиг компонент заданного вектора A(N) влево на одну

10-11 класс

позицию, то есть получите вектор А = (a2 , a3 , ..., aN , a1 ).

2) Имеется последовательность чисел a1, a2 , ..., aN . Найти сумму первых из них, произведение которых не превышает заданного числа М.

СИ++. #include <stdio.h>

#include <conio.h>

Алёна445 21 апр. 2015 г., 23:53:04 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Vaz4661000
22 апр. 2015 г., 2:12:30 (9 лет назад)

#include <iostream>
#include <algorithm>
#include <numeric>
#include <iterator>
#include <functional>
#include <cstdlib>
using namespace std;
const int SIZE = 20;
int arr[SIZE] = { -1, 1, 5, 2, -4, 0, 7, -2, 5, -9, 3,6,-9,0,-4,4,6,2,13,5 };
void Massiv()
{
cout << "new Array:" << std::endl;
copy(arr, arr + SIZE, std::ostream_iterator<int>(std::cout, " "));
cout << std::endl;

int memory= arr[0];

for (int k=0;k<SIZE-1;k++)
arr [k]=arr[k+1];
arr[SIZE-1]=memory;

cout << "new Array:" << std::endl;
copy(arr, arr + SIZE, std::ostream_iterator<int>(std::cout, " "));
cout << std::endl;}

 

int main()
{
Massiv();

system("pause");
return 0;
}

 

Второе не понял задания

Ответить

Другие вопросы из категории

помогите пожалуйста не понимаю эти меры

1,2Мб= сколько Кб
0,3Гб= сколько Мб
1024Мб= сколько Гб
2700Кб= сколько Мб
3600Битов= сколько Кб

Пожалуйста помогите составить программу.Заполнить массив из 500 элементов случайными числами в интервале [ 0 .. 100 ] . Отсортировать его по

возрастанию двумя способами – методом «пузырька» и методом «быстрой сортировки» .

1)Ввести целое число и найти произведение его четных цифр. Пример: Введите целое число: 1234. Произведение четных цифр числа 1234 равно

6.

2)Ввести целое число и определить количество черных и нечетных цифр.

Пример:

Введите целое число :12547

количество нечетных цифр:3

количество четных цифр:2

Читайте также

Помогите пожалуйста, очень нужно!

Программирование
Решить квадратное уравнения вида ax^2 + bx + c = 0
К решению математическая модель:
Дано:
Нужно:
Связь:
При:

Составить программу на языке Паскаль.Определите, кратно ли трем значение целочисленной переменной X. Если это имеет место, то выведите на печать

значение Х с соответствующим сообщением, если нет, то выведите на печать "нет".
Помогите, пожалуйста, очень нужно)

Помогите пожалуйста!Очень нужно!

Перевести из 2-ойсистемы счисления в 8-10; 16-10
10011101101₂ и
11110001101₂
_________________________________________
Затем Перевести из 10-й с.с.в 3-ю с.с
555₁₀ --> X₃ (C проверкой)
785₁₀ --> X₇ (С проверкой) 7-ю с.с

_________________________________________

+111011₂
1101₂

-111011₂
1100₂

х11011₂
101₂

10101110₂÷111₂



Вы находитесь на странице вопроса "ПОМОГИТЕ ПОЖАЛУЙСТА! ОЧЕНЬ НУЖНО!( 1)Осуществите циклический сдвиг компонент заданного вектора A(N) влево на одну", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.