Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

В Pascal

5-9 класс

составить программу, которая находит произведение чисел введённых с клавиатуры, пока это произведение не станет больше 500

настпапр 23 нояб. 2016 г., 7:41:14 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Tima2027
23 нояб. 2016 г., 8:17:09 (7 лет назад)

var rezultat: integer := 1; 
a: integer;
begin
  while true do
  begin 
    read(a);
    rezultat := rezultat * a;
    if rezultat >= 500 then break;
  end; 
 write('произведение:', rezultat);
end.

Ответить

Другие вопросы из категории

По заданным координатам точек А и В вычислите длину отрезка АВ

Пример входных данных:
ха=10
ya=2
xb=10
yb=7
с объяснением

Помогите пожалуйста))))(
Исправьте ошибки: а)IF 1<X<2 THEN X:=X+1; Y:=0;

ELSE X:=0; Y:=Y+1;

б)IF 1<X AND X<2

THEN BEGIN X:=X+1; Y:=0;
ELSE X:=0;Y:=Y+1; END;

Составьте блок-схему и запишите правильный вариант

Читайте также

Составить программу, которая выводит на экран в обратном порядке нечетные числа от 29 до 1 в Pascal ABC.

Составить программу,которая выводит на экран сумму нечетных чисел от 1 до 30 в Pascal ABC.


1.Какое значение переменной S будет напечатано после выполнения фрагмента программы,записанной на языке программирования TURBO PASCAL:A:=2В: = 3;

if A>B then S: = A+B;
writeln (S);
Варианты ответов:1)5 ;2)6; 3)7; 4)8

2. Какое значение переменной S будет напечатано после выполнения фрагмента программы, записанной на языке программирования PASCAL:
S: =1;
N: =1;
while N<=3 do
begin
S: = S*N;
N: = N+1;
end;
writeln(S);
Варианты ответов: 1)2 ; 2)1; 3)0; 4)4

1) дано четырёхзначное число. вывести максимальную и минимальную цифру. pascal abc

2) дано четырёхзначное число. Что больше: произведение цифр числа или их утроенная сумма. pascal ABC



Вы находитесь на странице вопроса "В Pascal", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.