Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Помогите, кто знает хорошо visual basic

10-11 класс

Нужно прописать в программе
Функция должна возвращать
Величину
среднего абсолютного отклонения
Отношение
среднего квадратического отклонения к среднему абсолютному отклонению
Среднее
арифметическое из средних абсолютных отклонений поддиапазонов

KaterinaKus 16 апр. 2013 г., 10:30:31 (11 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
аняярошевич
16 апр. 2013 г., 12:14:49 (11 лет назад)

Среднее абсолютное отклонение
MAD = Сумма (по i от 1 до n) |x(i) - ~x| / n
Программа
Sredx = 0
For i = 1 To n
   Sredx = Sredx + x(i)
Next i
Sredx = Sredx / n ' посчитали среднее арифметическое ~x
MAD = 0
For i = 1 To n
   MAD = MAD + Abs(x(i) - Sredx)
Next i
MAD = MAD / n ' посчитали среднее абсолютное отклонение

Среднее квадратическое отклонение
MQD = Sqrt(Сумма (по i от 1 до n) (x(i) - ~x)^2 / n)
Программа
MQD = 0
For i = 1 To n
   MQD = MQD + (x(i) - Sredx)^2
Next i
MQD = (MQD / n)^(1/2) ' посчитали среднее квадратическое отклонение
Otnos = MQD / MAD ' посчитали отношение квадратического к абсолютному

Среднее арифметическое из средних абсолютных отклонений поддиапазонов
Посчитай MAD в каждом поддиапазоне отдельно, а потом среднее арифметическое, как в цикле Sredx.

Ответить

Другие вопросы из категории

Program Series17;

var
a,B,N,i:integer;
bol:boolean;
begin
i:=0;
n:=0;
bol:=true;
Writeln('Введите число B');
readln(B);
Writeln('Введите число N');
Readln(N);
Writeln('Введите ',N,' целых чисел.');
While i < n

НАЙТИ средний бал за контрольную работу если кол-во учеников выполнявших работу n. Также найти колличество учеников которые получили оченку 4 или 5,а

также оченку 2

составить программу в гамбас(не обязательно программу если можно просто решение объяните)

Составьте программу, которая вводит с клавиатуры 8 целых

неотрицательных чисел (каждое число — с новой строки отдельной
командой «ввод»), записывает их в массив, выводит на экран сначала в
прямом порядке все без исключения элементы массива, затем, в обратном
порядке относительно следования в массиве, все чётные элементы.
Например, для массива «1 2 5 4 5 3 7 8» программа должна выводить
числа в таком порядке: 1 2 5 4 5 3 7 8 8 4 2.
Каждое число программа должна выводить в отдельной строке; ничего,
кроме чисел, программа выводить не должна.

Читайте также

Помогите кто знает !!!

10 и 11 вопрос

Табулирование функции с использованием цикла FOR,While и Until. Функция: F(x)=ln(3*x)*(sin(z*x)+1)/(ln(2+z)) 1,73=<x=<50 с шагом

dx=4,64;z=0,79;

Кто знает как делать,пожалуйста помогите)



Вы находитесь на странице вопроса "Помогите, кто знает хорошо visual basic", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.