Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

дан массив из 10 элементов,которые вводятся с клавиатуры. Найти: 1)наибольший элемент 2)Сумму неотрицаельных элементов

10-11 класс

3)Произведение четных элементов

Goliko20031 16 авг. 2014 г., 10:50:07 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
софия21
16 авг. 2014 г., 13:20:57 (9 лет назад)

var
    m : array [1..10] of Integer;
    i, b, s, p : Integer;
begin

 

   Writeln('Введите массив:');

   for i := 1 to 10 do

   begin
      Write(i, ': ');

      Readln(m[i]);

    end;

 

   s := 0;
   b := m[1];
   p := 1;

   for i := 1 to 10 do
   begin
      if b < m[i] then b := m[i];
      if m[i] > 0 then s := s + m[i];
      if m[i] mod 2 = 0 then p := p * m[i];
   end;

   Writeln('Наибольший элемент = ', b);
   Writeln('Сумма неотрицаельных элементов = ', s);
   Writeln('Произведение четных элементов = ', p);

   ReadLn;
end.

 

Ответить

Другие вопросы из категории

В школу привезли 24 компьютера и распределели их между кабинетами №20 и №30. Сообщение: "неисправный компьютер находится в кабинете №20" несёт три бита инф

ормации. Найдите, сколько компьютеров находится в кабинете №30. В ответе указать только число, например, 15.

Читайте также

№1. Дан массив из 30-ти элементов. Каждый элемент может принимать целочисленные значения от 0 до 100. Напишите программу, которая позволит найти сумму

двузначных элементов массива, которые не оканчиваются на 3. №2. Дан массив из 100 элементов. Каждый элемент может принимать целочисленные значения от 1 до 500. Напишите программу, которая позволит найти и вывести минимальное значение среди элементов массива, которые делят максимальное значение элементов массива без остатка.

№1. Дан массив из 30-ти элементов. Каждый элемент может принимать целочисленные значения от -100 до 100. Напишите программу, которая позволит

подсчитать среднее арифметическое положительных элементов массива, которые кратны первому элементу массива. №2. Дан массив из 40 элементов. Каждый элемент может принимать целочисленные значения от 0 до 200. Напишите программу, которая позволит найти наиболее часто встречающийся элемент массива

дан массив из семи элементов написать программу подсчитывающую

среднее второго и предпоследнего элементов массива
дан целочисленный
массив из 10 элементов написать программу находящую сумму элементов
массива красных 3 ил 5
дан целочисленный массив из 30 ти элементов
написать программу которая позволяет найти среднее арифметическое
положительных элементов массива

1. Задайте массив из 10 элементов с помощью датчика случайных чисел. Найдите среднее арифметическое нечетных элементов массива с нечетными

индексами. выведите на экран исходный массив и полученное среднее арифметическое.
2. Задайте массив из 10 элементов с помощью датчика случайных чисел. замените все элементы с четными индексами максимальными. Выведите на экран исходный и измененный массивы

1) В компьютер вводится результат для 10 абитуриентов. Вывести на экран фамилии и результат тех, кто попадает в интервал ( 10, 30) Подсчитать среднее

арифметическое.
2) Дан массив из 10 элементов. Определить 2х значные числа и которые заканчиваются на цифре 5.



Вы находитесь на странице вопроса "дан массив из 10 элементов,которые вводятся с клавиатуры. Найти: 1)наибольший элемент 2)Сумму неотрицаельных элементов", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.