Статистика
Всего в нашей базе более 4 327 657 вопросов и 6 445 963 ответов!

Дан массив A(N). Что больше: сумма элементов массива или максимальный элемент массива и на сколько.

10-11 класс

Написать программу! Спасибо)

Йцукывапролджэ00 24 сент. 2015 г., 18:30:22 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Nina1987
24 сент. 2015 г., 20:15:14 (8 лет назад)

Program enot;
const n= 5;
Var a: array [1..n] of integer;
i,max,s:integer;
begin
for i:= 1 to n do begin
read (a[i]);
s:=s+a[i];
end;
max:= a[1];
for i:= 1 to n do
if a[i]> max then max:= a[i];
if max>s then writeln('максимальный элемент массива больше суммы массива на ', max-s)
 else write ('сумма массива больше макс.эл. на ', s-max);
 end.

+ 0 -
Liketat
24 сент. 2015 г., 22:22:44 (8 лет назад)

ввод массива с клавиатуры?

Ответить

Другие вопросы из категории

Дано N=2558, M=AF16.

Какое из чисел K, записанных в двоичной системе, отвечает условию N<K<M?

помогите, отгадайте слово)
Люди, будьте добры, помогите, пожалуйста!!!

Выдели не присущую объекту операцию:


1. селектор

2. итератор

3. деструктор

4. цетектор

5. конструктор

Помогите пожалуйста, кто знает) с решением)

1.Сколько Кбайт информации содержится в сообщении размером 2 Мбайта?
2.Сколько байт информации содержится в сообщении размером 16 бит?
3.Сколько бит информации содержится в сообщении размером 4 байта?
4.Сколько Мбайт информации содержится в сообщении размером 3072 Кбайт?
5.Сколько байт информации содержится в сообщении размером четверть мегабайта?

Сделайте 2 номер.........

Читайте также

Составить программу Дан массив натуральных чисел , размерность -12 !) Заполнение массива производить с клавиатуры 2) Вывести на печать

только элементы кратные 2

3)Найти сумму первых пяти элементов

Составить программу Дан массив целых чисел , размерность -12

1) Заполнение массива производить случайными числами из диапозона [-10;35]

2)Вывести на печать только положительные элементы

3)Найти количество отрицательных элементов

Составить программу

Известны данные о выпуске прождукции ( ткани в метрах ) ткацким цехом текстильного комбината за каждый день месяца . Определить количество ткани ( метров) произведенных цехом за месяц .

на языке паскаль 1)дан массив натуральных чисел найдите сумму всех его элементов 2)вычислить количество положительных чисел

среди 10 элементов вещественного массива

3)заполнить массив из n целых чисел.выяснить какое число встречается раньше-положительное или отрицательное.

4)в целочисленном массиве есть отрицательные элементы.вывести номера этих элементов

Дан массив V[15] целочисленных элементов. Определить: 1)произведение элементов, занимающих 1,6,11 места в массиве. 2)сумму

элементов, занимающих четные места в массиве.

3)сформировать новый массив K [10] из элемаентов с 1 по 10 по формуле: K[i]=V[i]*2.

4)определить максимальный элемент массива K, его порядковый номер.

нужна программа, написанная, на языке програмирования Pascal.

1)дан массив натуральных чисел найдите сумму всех его элементов 2)вычислить количество положительных чисел среди 10 элементов вещественного

массива

3)заполнить массив из n целых чисел.выяснить какое число встречается раньше-положительное или отрицательное.

4)в целочисленном массиве есть отрицательные элементы.вывести номера этих элементов

Help!!! Дан массив целых чисел, состоящий из 10 элементов.Заполнить его с клавиатуры. Найти:

-Удвоенную сумму положительных элементов;

-Удалить все четные элементы массива.



Вы находитесь на странице вопроса "Дан массив A(N). Что больше: сумма элементов массива или максимальный элемент массива и на сколько.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.