Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

решить любые 2 задачи, пожалуйста!!! или хотя бы одну в PASKALe

5-9 класс

1. Найти те элементы массива, которые равны сумме двух своих соседей. Первый и последний элемент имеют только по одному соседу, поэтому искомыми быть не могут.
На вход программе сначало подается значение n<=100 – количество элементов в массиве. В следующей строке расположены сами элементы массива – целые числа, по модулю не превосходящие 10000. Выдайте значения искомых элементов массива в том же порядке, в каком они располагались во входных данных.

2. На вход программе подается последовательность чисел от 1 до 9, заканчивающаяся нулем. Всего будет введено не более 100000 чисел. Подсчитайте в этой последовательности количество единиц, количество двоек, количество троек и т.д. и выдайте результат. В выходных данных всегда должно быть 9 чисел.
3. Текст на английском языке запишите в массив a[1..1000] of char. Помимо английских букв в нем могут встречаться пробелы и знаки препинания. В массиве b [‘A’ ..’Z’’] of integer получите сведения о том, сколько и каких букв встречается в этом тексте. При подсчете строчные и прописные буквы не различать. На вход программе подается значение n<=1000 – количество символов в тексте. В следующей строке входных данных расположены сами символы (без разделителей). Выдайте 26 чисел – значения элементов массива b.
Пример

Входные данные
Выходные данные
12
Hello world!
0 0 0 1 1 0 0 1 0 0 0 3 0 0 2 0 0 1 0 0 0 0 1 0 0 0

4. Подсчитайте за один проход, сколько его элементов равны максимальному элементу.
На вход программе сначала подается значение n<=100 – количество элементов в массиве. В следующей строке входных данных расположены сами элементы массива – целые числа, по модулю не превосходящие 30000. Выдайте количество искомых элементов массива.

5. В массиве, заполненным произвольными целыми числами, найдите два числа, произведение которых максимально. Вложенные циклы не используйте. На вход программе сначала подается значение n<=10000 – количество элементов в массиве. В следующей строке входных данных расположены сами элементы – целые числа, по модулю не превосходящие 30000. Выдайте два искомых числа в порядке неубывания.
6. На вход программе сначала подается значение n<=100 – количество элементов в массиве. В следующей строке входных данных расположены сами элементы массива – целые числа, по модулю не превосходящие 30000. Распечатайте только те значения элементов массива, которые встречаются в нем ровно один раз. Элементы следует распечатывать в том порядке, в котором они встречаются в массиве.

Eldar1999 07 мая 2014 г., 12:20:34 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Petr0102
07 мая 2014 г., 14:18:44 (9 лет назад)

№ 2
var
n,i,j:integer;
s,s1:string;
begin
readln(S);
for n:=1 to 9 do
begin
str(n,s1);
for i:=1 to length(S) do 
if s[i]=s1 then
inc(j);
writeln('Цифр ',n,' всего ',j);
j:=0;
end;end.
№4


+ 0 -
Lisa2828
07 мая 2014 г., 14:50:34 (9 лет назад)

end; var c:char;     a:array[0..9] of cifry;     i,j:byte;     x:cifry; begin for i:=0 to 9 do  begin   a[i].zn:=i;   a[i].vs:=0;  end; writeln('Введите последовательность цифр, окончание точка:'); repeat c:=readkey; if c in cf then  begin   write(c);   inc(a[ord(c)-48].vs);  end; if c='.' then writeln until c='.'; for i:=0 to 8 do for j:=i+1 to 9 do if (a[i].vs>a[j].vs)or((a[i].vs=a[j].vs)and(a[i].zn>a[j].zn)) then  begin   x:=a[i];   a[i]:=a[j];   a[j]:=x;  end; for i:=0 to 9 do if a[i].vs>0 then write(a[i].zn); end.

Ответить

Другие вопросы из категории

Друзья, кто шарит в инфе?

Помогите плиз

Трем логикам предоставили следующий список слов:

ОДА ПАЛ СОР НОС ВАР

* Каждому из логиков назвали только по одной букве, при этом каждый знал только свою букву.
* Логикам сказали, что их три буквы складываются в слово из приведенного списка.
* Когда каждого логика спросили по очереди: «Знаете ли вы какое слово складывается из названных вам букв?», сначала первый ответил «ДА», затем второй ответил «ДА» и потом третий ответил «ДА».
* Каждый из логиков слышал ответ каждого другого.

Какое слово складывается из букв, названных логикам?

Читайте также

Пожалуйста помогите решить желательно все или хотя бы одну (P.S. программа для программы Turbo Pascal) 1.Написать программу, которая предлагает

ввести 3 значное число и находит сумму его цифр.

2. Написать программу, которая предлагает ввести 3 значное число и меняет порядок цифр наоборот. (123- 321)

3.Написать программу, которая предлагает ввести три числа с клавиатуры, находит их сумму, произведение и среднее арифметическое.

Люди Люди Люди если вы читаете это сообщение значит вы просто обязаны помочь! пожалуйста если у вас есть паскаль помогите пожалуйста решить первое и

второе задание ну или хотя бы только первое .Это вопрос жизни и смерти помогите пожалуйста P.S задание во вложениях.заранее спасибо и знайте если вы поможете значит вы самый добрый и отзывчивый человечек!)

Решите,пожалуйста,хотя бы одну из данных задач:

1)Написать программу,подсчитывающую сумму положительных из трех данных чисел.
2)Напечатать те из двузначных чисел которые делятся на 4,но не делятся на 6.
СРОЧНО!!!

Пожалуйста, помогите) Очень важно) Решите хотя бы одну задачу... А если не сложно, то лучше 2 :))) 1) Информационная ёмкость

человеческой яйцеклетки приблизительно равна 2 в 33 степени битов. Сколько дискет ёмкостью 1,4 МБайт потребуется для размещения этой информации ?

2) Дискета объёмом 1440 КБайт весит 20 г. Сколько будет весить набор дискет, необходимый для полногокопирования информации с жёсткого диска объёмом 80 ГБайт ?

Заранее огроооомное спасибо :)



Вы находитесь на странице вопроса "решить любые 2 задачи, пожалуйста!!! или хотя бы одну в PASKALe", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.