Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Напишите программу, которая позволит определить количество дней в течение заданного периода, в которые не было прибыли, и максимальную выручку за этот

5-9 класс

период. Прибыль за день определяется как разность "выручка"-1000 (рублей) (если разность отрицательна, считать прибыль равной 0).

На входе программа получает период N

Nasyusha 30 янв. 2015 г., 17:12:37 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Mynameipis
30 янв. 2015 г., 18:01:41 (9 лет назад)

через генератор случайных чисел
program noname;
uses crt;
var
n,k,i:integer;
a:array[1..1000] of longint;
max:longint;
begin
clrscr;
write('vvedi period n=');
readln(n); k:=0;
for i:=1 to n do begin
randomize;
a[i]:=random(10000);
writeln(a[i]);
if a[i]-1000<0 then k:=k+1;
end;
max:=a[1];
for i:=2 to n do
if max<a[i] then max:=a[i];
writeln(k,'-дни без прибыли ',max,'-максимальная выручка');
end.

Ответить

Другие вопросы из категории

Помогите решить:

1.В память ПК вводится текст со скоростью 180 символов в секунду.Сколько потребуется времени для заполнения 22,5Кб ?
2.Известно, что на странице помещается 32 строки по 64 символа.Какое макс. количество страниц текстовой информации поместится в файл объёмом 640Кб ?

какие слова зашифрованы

1) ?=%№
2) @:$:@
3) %!%(%
4) *%+*
5) @^$#@
(киоск,торт,шалаш,олово,книга)

Читайте также

решите пожалуйста задачи:* 1)в корзине лежит 12 шаров.Определить количество информации,содержащие в сообщение,о том что взяли один шар. 2)сообщение

содержит 1 кбайта информации и состоит из 2048 символов.определить количество символов в алфавите,с помощью которого написано сообщение.

РЕШИТЕ ХОТЬ ЧТО-НИБУДЬ!!!:з 1.Линейные программы Напишите программу на ШАЯ.Вычислите значения следующих выражений: f=t*t/2+t

2.Условный оператор(ветвление)

Нарисуйте блок-схему.Дано два числа.Верно ли, что он равны?

3.Циклы

Напишите программу на Паскале. Выведите на экран табицу умножения на 4 в виде 1+4=4,2+4=8,....9*4=36.

4.Одномерные массивы

Напишите программу на Паскале.Подсчитайте количество максимальных элементов массива А [1..12].

5.Двумерные массивы

Напишите программу на Паскале. создать массив случайны чисел В[1..6,1..6].Все элементы массива, расположенные выше главной диагонали сделать равными О.Вывести исходный и исправленный массивы.

Решение задач с использованием массивов / Pascal (Паскаль)

Помогите, пожалуйста, решить задачу!

Определить количество дней в первой декаде месяца, когда температура была выше средней.
Исходные данные: T - массив температуры
Промежуточные данные: i - порядковый номер
SUM - суммированная температура за 10 дней
SRT - средняя температура за 10 дней
Результирующие данные: K - количество дней с температурой выше средней
SUM:=SUM+T[i]
SRT:=SUM/10
K:=K+1, если выполняется SRT<T[i]
_______________________________
Program KTD
var T:array [1..10] of real;
SUM, SRT:real;
i,K:byte;

1)Напишите программу,которая в последовательности целых чисел определяет количество трехзначных чисел,не кратных 5 и 7 и не заканчивающ

ихся 0 или 1.
Программа получает на вход целые числа от -3000 до 3000.

2)Напишите программу,которая в последовательности целых чисел вычисляет среднее арифметическое среди двухзначных чётных чисел,делящихся на 3.
НУЖНО СЕГОДНЯ! 66 БАЛЛОВ!

Напишите программу, которая в последовательности целых чисел определяет количество чисел, кратных 4 и оканчивающихся на 0. Программа получает на вход целые

числа, количество введеных чисел неизвестно, последовательность чисел заканчивается числом 0 (0-признак окончания ввода, не является членом последовательности). Количество чисел не превышает 1000. Введеные числа по модулю не превышают 30000. Программа должна вывести число: количество чисел, кратных 4 и оканчивающихся на 0.



Вы находитесь на странице вопроса "Напишите программу, которая позволит определить количество дней в течение заданного периода, в которые не было прибыли, и максимальную выручку за этот", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.