Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

даны натуральные числа А и В (В<А). написать программу , выводящую на экран сумму натуральных чисел от В до А, включая В и А.

1-4 класс

BMP007 03 июля 2016 г., 20:24:10 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Shuanka53
03 июля 2016 г., 22:42:36 (7 лет назад)

uses crt;const  h=10;var  a,b,S: integer;
begin  write('A= '); readln(a);  write('B= '); readln(b);  S:=0;  while b<>a+1 do  begin    S:=S+b;    inc(b);  end;  writeln('Сумма - ',S);end.

+ 0 -
ТанечкаКсюшка
04 июля 2016 г., 1:13:53 (7 лет назад)

var a,b,sum:integer;
begin
readln(a,b);
for b:=b+1 to a do
sum:=sum+b;
writeln(sum);
end.

+ 0 -
Sergel
04 июля 2016 г., 4:11:03 (7 лет назад)

Комментарий удален

Ответить

Читайте также

Напишите программу, которая

позволяет ввести три вещественных числа и выводит на экран:


сумму
всех трех чисел;
модуль
разности первого и второго чисел;
целую
часть произведения второго и третьего чисел.


Все вещественные числа должны быть
выведены в форме с фиксированной точкой с двумя знаками после запятой; перед
каждым вычисленным значением должны идти пояснительный текст и выражение.

Напишите программу, которая вводит два вещественных числа, a и b ( a < b ), и выводит через пробел 5 случайных вещественных чисел в полуинтервале [ a ,

b ) .

Входные данные
Входная строка содержит два вещественных числа a и b , разделённых пробелом. Гарантируется, что a < b .

Выходные данные
Нужно вывести в одной строке через пробел 5 случайных вещественных чисел в полуинтервале [ a , b ) с тремя знаками в дробной части.



Вы находитесь на странице вопроса "даны натуральные числа А и В (В&lt;А). написать программу , выводящую на экран сумму натуральных чисел от В до А, включая В и А.", категории "информатика". Данный вопрос относится к разделу "1-4" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.