Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Помогите срочно!

10-11 класс

Составить алгоритм через паскаль.Введите с клавиатуры три числа авс.если а=в.то все числа замените квадратами если а>b>c то каждое число замените наибольшим, иначе: а сделайте равным сумме в и с, с обнулите, в оставьте без изменения»

Серёжа98 19 янв. 2014 г., 13:14:41 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Adelinchik040601
19 янв. 2014 г., 15:38:30 (10 лет назад)

var
  a, b, c : integer;
begin
  read (a, b, c);
  if a = b then
  begin
    a := sqr (a);
    b := sqr (b);
    c := sqr (c);
  end
  else if (a > b) and (b > c) then
  begin
    b := a;
    c := a;
  end
  else
  begin
    a := b + c;
    c := 0;
end;
  write (a, ' ', b, ' ', c);
end.

Ответить

Другие вопросы из категории

Однажды один системный администратор увидел, что его сервера упали, и после недолгого выяснения причин, стало известно, что на сервер была совершена

DDoS-атака из 5 разных точек. Интервалы атаки из разных точек разные и атаки совершаются соответственно с интервалом в 1 час, 2 часа, 3 часа, 4 часа и 5 часов. Сервер не выдерживает нагрузки только если его атакуют сразу из 5 точек одновременно. Скажите, сколько часов есть у администратора, чтобы закрыть доступ к серверу до того как он(сервер) перестанет работать из-за успешной атаки?
1) 120
2) 60
3) 40
4) 10

Введите с клавиатуры 8 положительных целых чисел. Определите, сколько из

них делится на 3 и оканчивается на 4. Программа должна вывести одно число:
количество чисел, кратных 3 и оканчивающихся на 4.

Для регистрации на сайте некоторой страны пользователю необходимо придумать пароль длиной ровно 15 символов. В пароле можно использовать десятичные

цифры и 11 различных символов местного алфавита, причем все буквы используются в двух начертаниях - строчные и прописные. Каждый символ кодируется одинаковым и минимально возможным количеством бит, а каждый пароль - одинаковым и минимально возможным количеством байт. Определите объем памяти, необходимый для хранения 30 паролей.

Если длина I=11 ; Количество букв М=32 ; Количество номеров И=20 .


В чём ошибка программы? Если не сложно объясните .

код программы -
Program cikl;
Uses GraphABC;
Var
r:Integer;
begin
for r:=460 downto 100 do
begin
circle(620,480,r);
r:=r-35;
end;
FloodFill(170,480,clPurple);
FloodFill(205,480,clBlue);
FloodFill(240,480,clSkyBlue);
FloodFill(275,480,clGreen);
FloodFill(310,480,clYellow);
FloodFill(345,480,clLime);
FloodFill(380,480,clMoneyGreen);
FloodFill(415,480,clRed);
FloodFill(450,480,clMaroon);
FloodFill(485,480,clBrown);
FloodFill(620,480,clNavy);
End.


Ошибка которую выдаёт программа -
Program1.pas(9) : Нельзя изменять значение переменной цикла внутри этого цикла

Читайте также

Помогите срочно!!

Даю 20 баллов

массив помогите срочно хера
Помогите срочно, надо вариант 4! Сделать при помощи VBA и проверить в экселе

Вычислить значение функции по формуле. Значение аргумента x принадлежит[0,1;0,6]
вариант 4

помогите срочно!!!!!!!!!!!


Вы находитесь на странице вопроса "Помогите срочно!", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.