Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

найти строку двумерного массива с наименьшей суммой элементов

10-11 класс

язык паскаль , const n=4;m=2;

Mamagnom 04 апр. 2014 г., 1:12:51 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Mif7696
04 апр. 2014 г., 1:44:15 (10 лет назад)

program naim;
const n= 4;
      m = 2;
var a: array [1..n, 1..m] of integer;
    s: array [1..n] of integer;
    i, j, min: integer;
begin
for i:= 1 to n do begin
s[i]:=0;
for j:= 1 to m do
read (a[i,j]);
writeln (''); end;

for i:= 1 to n do
for j:= 1 to m do
s[i]:=s[i]+a[i,j];

j:=1;
min:=s[1];
for i:= 2 to n do
if s[i]<min then begin
min:= s[i];
j:=i; end;


writeln ('');
writeln ('Номер строки с минимальной суммой: ', j);
end.


+ 0 -
Makolga
04 апр. 2014 г., 3:42:13 (10 лет назад)

в каком языке программирования? и размеры массива какие?

+ 0 -
Gosha2211
04 апр. 2014 г., 6:37:10 (10 лет назад)

паскаль

+ 0 -
Дирешионер
04 апр. 2014 г., 8:03:38 (10 лет назад)

const n=4; m=2;

Ответить

Другие вопросы из категории

Здравствуйте! Помогите решить задания! Не понимаю программу Кумир, к сожалению, завтра последняя возможность исправить оценку. заранее

спасибо

1. Напечатать числовой ряд: 1,7,13,19,25,31,……….61 с помощью цикла «пока».

2. Написать программу, которая запрашивает число с клавиатуры и сообщает его квадрат, затем спрашивает пользователя «Нужно продолжить работу?», и пользователь отвечаетда/нет. Программа заканчивает свою работу, если пользователь напечатал слово «нет» на очередной вопрос программы, иначе считает и выдаёт ответ дальше.

3. Дан массив из 10-ти чётных натуральных чисел – от 2 до 20.

А) Найдите сумму элементов массива.

Б) Найдите минимальный элемент массива.

4. Дан массив из 15 подряд идущих натуральных чисел, начиная с 50.

А) Найдите произведение элементов массива.

Б) Найдите максимальный элемент массива.

Автоматическое устройство выполнило перекодировку информационного сообщения на русском языке, которое было записано в 8-битовой кодировке КОИ-8 в

16-битовый код Unicode. При этом объем сообщения увеличился на 288 бит. Сколько символов в сообщении?

Помогите срочно надо Вариант 1. 78 48 35 5 50 44 75 38

Упражнение 1.
Выполните сортировку элементов из вашего варианта методами: пузырьком,вставками, бинарными вставками, выбором. Приведите примерыпоследовательностей, показывающих, что сортировки выбором, бинарнымивставками являются неустойчивыми.Упражнение
2.
Упорядочите элементы из вашего варианта по неубыванию следующимисортировками: быстрой, пирамидальной. Приведите примеры последовательностей,показывающих, что быстрая и пирамидальная сортировки являются неустойчивыми

Читайте также

Паскаль, составьте программу для двумерного массива:

Найти произведение отрицательных элементов указанной строки двумерного массива размером 4*5 целых чисел.

1)напишите программу формирования массива размеров 5 х 5 с помощью датчика случайных чисел.замените в нем все четные значения элементов суммой

индексов элементов главной диагонали.Выведите на экран исходный и измененный массивы (программа на языке Паскаля)
2)Составьте программу формирования и вывода на экран одномерного массива, состоящего из удвоенных минимальных элементов строк двумерного массива, заданного с помощью датчика случайных чисел

Дано: массивы R(10),Q(10),P(10). Сформировать массив X(3),где X(1) - сумма элементов массива R, значения которых лежат в интервале [2;4];

X(2) - то же для массива Q;

X(3) - то же для массива P.

Вычисление суммы элементов массива, значения которыхлежит в интервале [2;4], оформить в виде подпрограммы.

PascalABC

Вот такие задачи нам задают.Прошу помощи.Заранее спасибо =)



Вы находитесь на странице вопроса "найти строку двумерного массива с наименьшей суммой элементов", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.