Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Ребята!Помогите пожалуйста!Работаем в PascalABC.Нужно составить программу,которая строит изображения предмета в плоском зеркале(расстояние от предмета

10-11 класс

до зеркала вводятся с клавиатуры).Очень срочно.Заранее спасибо)

Zika 31 дек. 2016 г., 6:35:19 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Jfjsdmlkgdfjk
31 дек. 2016 г., 9:02:21 (7 лет назад)

Картинка должна находиться в папке программы и иметь расширение .jpg. У меня по умолчанию название папки PABCWork.NET. И размер картинки бери не большой))

 

 

 

 

 

uses
graphabc;
var
a:string;
b:picture;
c:integer;
begin
writeln('Введите расстояние до зеркала');
readln(c);
writeln('Введите имя файла рисунка (.jpg): ');
readln(a);
window.Clear;
b := Picture.Create(a);
b.Load(a);
b.Draw(50, 50);
b.FlipHorizontal;
b.Draw(300+5*c,50);
end.

Ответить

Другие вопросы из категории

Ребят, помогитее плиз!

Значок условного перехода на блок-схеме как выглядит?

2 кбайтов это сколько битов
пожалуйста,помогите решить!!!

Читайте также

Напишите прог-у на паскале... ПЛИИИИИИИИИИЗ 1)даны действительные числа a1, b1, c1, a2, b2, c2. Составьте программу, которая находит координаты точки

пересечения прямых, описываемых уравнениями a1x+b1x=c1 и a2x+b2x=c2. Если прямые пересекаются или не существуют-выдать соответствующее сообщение. 2) даны действительные числа a1, b1, a2, b2. Составьте программу, которая определяет, какая из точек A(a1;b1) или B(a2;b2) лежит на прямой у=2х+1. Если такой точки нет-вывести соответсвующее сообщение.

Ребята, помогите пожалуйста!!!

У вас было а рублей, вы купили 10 тетрадей по в рублей, 1 дневник по с рублей и 3 ручкм по п рублей. Составить программу , выводящую количество вашей сдачи.,

Нужно составить программу с предусловием и постусловием!

Составить программу к.т. запрашивает буквы, пока не введут точку и находит количество букв "0".

Составить программу, которая формирует файл записей, содержащих информацию об автомобиле (название модели, год выпуска, цена, цвет), а также найти в

массиве записей и вывести на экран названия моделей красного цвета, випускалиcя в 2000 году.

P.s Помогите пожалуйста, заране огромное спасибо.



Вы находитесь на странице вопроса "Ребята!Помогите пожалуйста!Работаем в PascalABC.Нужно составить программу,которая строит изображения предмета в плоском зеркале(расстояние от предмета", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.