Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Задача 1 Составить программу При поступлении в вуз абитуриенты , получившие "двойку" на первом экзамене , ко второму не допускаются . В

10-11 класс

массиве A[n] записаны оценки экзаменующихся , полученные на первом экзамене . Подсчитать , сколько человек не допущено ко второму экзамену .

Задача 2

В одномерном массиве , состоящем из n вещественных элементов , вычислить ;

1) минимальный элемент массива;

2)сумму элементов массива , расположенных между первым и последним положительными элементами .

Преобразовать массив таким образом , чтобы сначала располагать все элементы , равные нулю, а потом-все остальные .

ловало 14 авг. 2014 г., 19:01:55 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Konoooz
14 авг. 2014 г., 21:39:13 (9 лет назад)

Задача1

массив определи как array[];

чтобы посчитать, просто используй счетчик, но сначала инициализируй переменную, которая содержит ответ задачи:

int n;

array [n];

int answer;

for (i=0, i < n, i++)

{

     if (array[i] == 2)

         answer++;

std::cout<<answer;

Как то так

 

Задача2 

 

array[n];

 

 

for (int i =1, i < n, i++)

{

 if (array[0] >= array[i])

    array[0] = array[i];

}

std::cout << array[0];

//Это было решение первого пункта

int first;

int last

bool positive;

while (positive == false )

{

   for (int i = 0; i < n; i++)

     {

        if (array[i] > 0)

        {

          positive = true;

          first = i;

          array[i] = -1;

      }

}

while (positive == false )

{

   for (int i = 0, i < n, i++)

     {

        if (array[i] > 0)

        {

          positive = true;

          last = i;

      }

}

 

 

int summ

for (int i = first, i < last, i++)

{

  summ += array[i];

}

 std::cout<<summ; // Ответ на 2 пункт

// ПРеобразую

newarray [n];

int a = 0;

for (int i = 0, i < n, i++)

{      

 if (array[i] == 0)  

   {      

newarray[a] = array[i];      

 a++;      

    }  

for (int i = 0, i < n, i++)

{    

     if (array[i] != 0)    

         {        

          newarray[a] = array[i];

         a++;

        }

}

std::cout<< newarray;

Ответить

Другие вопросы из категории

что такое логический элемент компьютера?

подскажите пожалуйста

Объем видеопамяти составляет 62,5 Мбайт. Графический дисплей

работает в режиме 320 x400 пикселей. Какое максимальное
количество цветов может содержать палитра?

Можно ли в программеMS Excel копировать формулы с ячейками?

А) да, но только если ячейка содержит формулу с абсолютной ссылкой
Б. Нет
В.да, любую ячейку с любыми йормулами
Г. Да, но только, если ячейка содержит формулу относительной ссылкой

Читайте также

Ребят, помогите! Тема: одномерные массивы. Две задачи:1) Написать прог

Ребят, помогите! Тема: одномерные массивы. Две задачи:

1) Написать программу, которая из заданного одномерного массива размерности N находит сумму только тех элементов, значения которых больше некоторого значения S.
S=5; Массив: 0,4 5,6 -2 10,1


2) При поступлении в ВУЗ абитуриенты, получившие "Двойку" на первом экзамене, ко второму не допускаются. В массиве A[N] записаны оценки экзаменующихся, полученных на первом экзамене. Подсчитать, сколько человек не допущено ко второму экзамену!

Заранее благодарю!

при поступлении в вуз абитуриенты получившие двойку на первом экзамене ко второму не допускаются. в массиве A[n] записаны оценки экзаменующихся,полученные

на первом экзамене. подсчитать, сколько человек не допущено ко второму экзамену .В Turbopascal

При поступлении в институт абитуриенты, получившие двойку на первом экзамене, ко второму недопускаются. В массиве А записаны оценки экзаменующихся.

Подсчитать, сколько человек недопущено ко второму экзамену.
"язык паскаль"

помогите составить программу!пожалуйста!!!!ооочень надо

ракета запускается с земли со скоростью V(км час) в направлении движения земли по орбите вокруг солнца. составить программу,определяющую результат запуска ракета в зависимости от скорости V.
Известно,что при V16,4 ракета покинет солнечную систему.

1. Составить программу для нахождения наибольшего числа из трех чисел.

2. Составить программу для упорядоченное двух элементов по убыванию.



Вы находитесь на странице вопроса "Задача 1 Составить программу При поступлении в вуз абитуриенты , получившие "двойку" на первом экзамене , ко второму не допускаются . В", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.