Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

Найти значение функции для х от 0 до 16 с шагом 1. Написать в виде программы

10-11 класс

Rizelmina 22 янв. 2014 г., 4:22:32 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Kivixdi
22 янв. 2014 г., 6:36:11 (10 лет назад)

Если в верхней строчке не "-3,5", а просто 3,5, то тогда вот такая программа:
var
   F:real;
   x:integer;
begin
writeln(' x','F':6);
for x:=0 to 16 do
  begin  if x>=3.5 then F:=4*x*x+2*x-19
    else F:=-2*x/(-4*x+1);
  writeln(x:2,F:8:2);
  end
end.

+ 0 -
Qw1er2ty3
22 янв. 2014 г., 8:27:45 (10 лет назад)

Мне кажется, в условии опечатка. Допустим, х=1. Тогда х>=-3,5 и х<1. Т.е. выполняется и первое, и второе условие. Такого быть не должно. Скорее всего, знака "минус" не должно быть.

Ответить

Другие вопросы из категории

Доброго времени суток, помогите пожалуйста с решением данной задачи, необходим код, для Turbo Pascal. Сама задача звучит так:

С клавиатуры вводится 3 числа, если сумма первого и последнего больше 10, то вывести эту сумму, если произведение больше 20, но меньше 30 (20>>30) то вывести это произведение, в противном случае вывести все эти 3 числа.

Решите пожалуйста !!!! очень надо!!!!!
дан фрагмент программы:

m:=14
n-m-3
m:n+m
write (m,n);
какие числа будут выведены на экран?

Читайте также

1)Вычислить значения функции y=4*x^3-2*x^2+5 для x, изменяющегося от -3 до 1 с шагом 0,1 на языке ПАСКАЛЬ!!СРОЧНОО ЗАВТРА ЭКЗАМЕН РЕБЯЯТКИ!

2)Найти количество всех нечетных чисел на интервале от 11 до 20
3)Найти сумму целых положительных четных чисел на интервале от 1 до 100
4)Найти сумму ряда,общий член которого равен А(х)=1/(3*N-2)*(3*N+1)
5)Дано произвольное число n≤100.Определить количество цифр в числе
ОЧЕНЬ НУЖНО!!НА ЯЗЫКЕ ПАСКАЛЬ!ВЫРУЧАЙТЕ!

Определите значение целочисленной переменной S после выполнения операторов: нц для i от 1

до 3 S:=0 нц для j от 2 до 3 S:=S+i+j кц кц
ПОМОГИТЕ

В программе используется одномерный целочисленный массив А с индексами от 0 до 10. Ниже представлен фрагмент программы в котором значения элементов

сначала задаются,а затем меняются.

Нц для i от 0 до 10

А [ i ] := i

кц

Нц для i от 0 до 4

С := A[ i ]

A[ i ] := A [10 - i ]

A [10 - i ] :=C

кц

Чему будут равны элементы массива после выполнения фрагмента программы?

1) 10 9 8 7 6 5 4 3 2 1 0

2) 0 1 2 3 4 5 6 7 8 9 10

3) 10 9 8 7 6 5 6 7 8 9 10

4) 0 1 2 3 4 5 4 3 2 1 0

Cоздать пользовательскую функцию и построить ее график для х от -5 до +5,с шагом 0,5 Y=\begin{cases}2cos^2(x),x ≤0\\ |2-x |^1/3,x

>0\end{cases}.

Функцию я построить сама смогла б,но я не знаю как туда это уравнение записать.можно ли его как -то упростить,чтоб все в одной строчке было.Вот фото уравнения на всякий случай,вдруг я его не правильно написала.Помогите пожалуйста.Тут в Excele надо работать



Вы находитесь на странице вопроса "Найти значение функции для х от 0 до 16 с шагом 1. Написать в виде программы", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.