Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 975 ответов!

2)Дан фрагмент программы на языке паскаль, на вход которого поданы значения N=10 и M=2. Чему будет равно на выходе из фрагмента значение SUM?

1-4 класс

SUM:=0; K :=M-1;

while K<N do

begin

for I(ай) := K-M+2 to K do SUM:=SUM+I;

K:=K+M;

end;

for I:=K-M+2 to N-1 do SUM:=SUM+I;

3)Программист Авсилий Кардов недавно получил банковскую карточку. Чтобы не забыть пароль к карточке, Василий решил построить его по алгоритму, а именно: пароль равен количеству чисел от 1 до 10000, не делящихся на 13 и 17. Чему равен пароль Васи?

4) Какой набор символов будет выведен в результате работы следующей программы?

function f(x:string; a:byte) :string;

begin

if a<=3 then

f:=copy(x, l, a)

else

f:=f(copy (x, 2, a), a-2;

end;

begin

writeln(f('abcdefghijklm',7));

end.

Tanyako4urovsk 01 нояб. 2014 г., 22:46:56 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Yaysssssssssss
01 нояб. 2014 г., 23:28:06 (9 лет назад)

Я уже тоже ришал весь кит, только на 2 ответ не помню.
3)10000-588(делятся на 17)-769(на 13)=8643 

Ответить

Читайте также

спставьте программу на языке Pascal: Для ремонта кабинета шириной а метров, длиной b метров, высотой h метров необходимо купить в магазине

обоев. Площадь окон и дверей не учитывать. Известна стоимость одного рулона (86 рублей) обоев длиной 12 м и шириной 0,6 м. Составьте программу определяющую, какая сумма необходима для покупки обоев.

Даны действительные числа x,y,z Если все числа положительны, увеличить их значения в 2 раза;во всех отальных случаях отрицательные числа заменить их

модулями, а положительные оставить без изменения.(Надо написать программу на паскале)



Вы находитесь на странице вопроса "2)Дан фрагмент программы на языке паскаль, на вход которого поданы значения N=10 и M=2. Чему будет равно на выходе из фрагмента значение SUM?", категории "информатика". Данный вопрос относится к разделу "1-4" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.