Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Циклические алгоритмы.СоставьтеЦиклические алгоритмы.Составьте блок- схему для решения следующих задач:

10-11 класс

1) Вводятся 100 чисел.Определить сколько среди них положительных и сколько отрицательных.(Числа вводятся в одну переменную в цикле)
2) Алгоритм вычисления суммы квадратов десяти производных чисел, водимых с клавиатуры в процесс выполнения алгоритма
И НАПИШИТЕ ПРОГРАММУ ДЛЯ КАЖДОЙ ЗАДАЧИ

BrusUilis2003 30 нояб. 2014 г., 8:14:56 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Rosa2013
30 нояб. 2014 г., 11:05:51 (9 лет назад)

1)
 var a,i ,b,c:integer;
begin
b:=0
c:=0
for i = 1 to 100 do 
begin
readln (a);
if a>0 then
b:=b+1;
if b<0 then
c:=c+1;
end;
writeln (b);
writeln (c);
end.



2)
var a,b,i:integer;
begin
b:=0;
for i = 1 to 10 do
begin
readln (a);
a:=a*a;
b:=b+a;
end;
writeln (b);
end.
вроде так


+ 0 -
Dodezdemon
30 нояб. 2014 г., 13:47:09 (9 лет назад)

Комментарий удален

+ 0 -
Артур03075
30 нояб. 2014 г., 14:18:56 (9 лет назад)

я же говорю, что понятия не имею как правильно составлять блок-схемы.

+ 0 -
Viktoraia2345
30 нояб. 2014 г., 17:07:11 (9 лет назад)

Комментарий удален

+ 0 -
Victoma
30 нояб. 2014 г., 18:40:21 (9 лет назад)

нет

+ 0 -
Fit
30 нояб. 2014 г., 19:25:57 (9 лет назад)

когда-то понимал, а сейчас уже нет

Ответить

Другие вопросы из категории

НАПИСАТЬ ПРОГРАММУ!ПОМОГИТЕ!!!

while и repeat
1)напечатать все отрицательные числа из диапазона от а до б, с шагом h.
2)Напишите программу, при выполнении которой с клавиатуры считывается натуральное число N, не превосходящее 10^9, и выводится сумма четных цифр этого числа и 0, если таких цифр в числе нет

не знаю видно нет

помогите решить))


Читайте также

Помогите пожалуйста! 1)Построить развлетвляющийся алгоритм, записать алгоритмы ввиде блок-схемы и на алгоритмическом языке. Треугольник задан

длинами своих сторон – a, b, c. Определить является ли

он тупоугольным, прямоугольным или остроугольным.

2) Построить циклический алгоритм, записать ввиде блок-схемы и на алгоритмическом языке.

Построить алгоритм, который определяет количество студентов в группе,
чей рост превышает среднее для группы значение.

Написать псевдокод (или блок схему) и код программы

для решения следующей задачи: Подсчитать разницу произведения и частного
двух чисел, вводимых с клавиатуры. Результат вывести на экран

прошу помочь, если знаете! зараннее спасибо))!



Нужно составить блок-схему алгоритма подготовки к сдаче к экзамену.

Я не могу сочинить этот "алгоритм", помогите ;)
Блок-схемы строить не надо, просто описать, что надо делать.

Дан фрагмент программы. Нарисуйте блок-схему, восстановите вид формулы для расчета S

PASCAL:

VAR
A:ARRAY[1...100]OFF
INTEGER;
N,I,J: INTEGER;
S: REAL;
BTGIN
N:=8;
FOR I:=1 TO N DO
BEGIN
S:=0;
FOR J:=1 TO I DO
S:=S+(A[J]);
S:=ABS(S);
WRITELN(`S`=`,S:9:2);
END;
READLN;
END.

QBASIC
DEFINT N,I,J,S,
DIM A(100) AS INTEGER
N:=8
FOR I=1 TO N
S=0
FOR J=1 TO I
S=S+A[J]
NEXT J
S=ABS(S)
PRINT S
NEXT I

ШКОЛЬНЫЙ АЯ

алг слово(рез вещ s)
цел раб А[1:100]
n:=8
нц для I от 1 до n
s=0
нц для j от 1 до I
s=s+a[j]
кц
s=abs(s)
вывод s
кц
кон

Пожааалуйста нужны блок-схемы для трех вариантов получения s







Вы находитесь на странице вопроса "Циклические алгоритмы.СоставьтеЦиклические алгоритмы.Составьте блок- схему для решения следующих задач:", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.