Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 975 ответов!

1)По данному числу n вычислите сумму 2(1-1/3+1/5-1/7+...+(-1)n/(2n+1)). Формат входных данных: Вводится одно число n, не превосходящее 100000.

10-11 класс

Формат выходных данных: Необходимо вывести значение выражения 2) Вводятся 4 числа: a, b, c и d. Выведите все числа на отрезке от a до b,не дающие остаток c при делении на d 3) Подсчитайте, сколько среди данных N чисел нулей, четных чисел, нечетных чисел. Вводится число N, а затем N чисел. Необходимо вывести сначала число нулей, затем число четных и нечетных чисел 4) электронное устройство, выдает каждую секунду очередное число последовательности 1, 2, 2, 3, 3, 3, 4, 4, 4, 4, 5... Ввиду дороговизны электронных комплектующих вам поручено разработать эмулятор для этого устройства. Формат входных данных: Дано количество секунд (от 1 до 1000000), которые работает генератор после включения. Формат выходных данных: Результат работы генератора(пример 2 1 2 5 1 2 2 3 3) 5)Вклад в банке составляет x рублей. Ежегодно он увеличивается на p процентов, после чего дробная часть копеек отбрасывается. Каждый год сумма вклада становится больше. Определите, через сколько лет вклад составит не менее y рублей.Программа получает на вход три натуральных числа: x, p, y и должна вывести одно целое число 6)Исполнитель “Раздвоитель” преобразует натуральные числа. У него есть две команды: “Вычесть 1” и “Разделить на 2”, первая команда уменьшает число на 1, вторая команда уменьшает число в два раза, если оно чётное, иначе происходит ошибка.Дано два натуральных числа A и B (A>B). Напишите алгоритм для Развоителя, который преобразует число A в число B и при этом содержит минимальное число команд. Команды алгоритма нужно выводить по одной в строке, первая команда обозначается, как -1, вторая команда как :2.

Aselka03 08 янв. 2015 г., 13:13:50 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Ykotsiban
08 янв. 2015 г., 16:12:39 (9 лет назад)


var
  a, b, c, d, i, n, p: integer;
  x, y: real;

begin
  writeln('Задача 1, введите n =');
  read(n);
  for i := 1 to n do
    if i mod 2 = 0 then
      x := x + 1 / (2 * i + 1)
    else x := x - 1 / (2 * i + 1);
  writeln('Sum = ', x);
 
  writeln('Задача 2, введите a, b, c, d =');
  read(a, b, c, d);
  for i := a to b do
    if i mod c = d then writeln(i);
 
  writeln('Задача 3, введите n и n чисел =');
  read(n);
  a := 0; b := 0; c := 0;
  for i := 1 to n do
  begin
    read(p);
    if p = 0 then a := a + 1
    else if p < 0 then b := b + 1
    else if p > 0 then c := c + 1;
  end;
  writeln(a, ' ', b, ' ', c);
 
  writeln('Задача 5, введите x, p ,y =');
  read(x, p, y);
  n := 0;
  repeat
    x := round(x * (100 + p)) / 100;
    n := n + 1;
  until x >= y;
  writeln(n, ' лет');
 
  writeln('Задача 6, введите A, B =');
  read(a, b);
  repeat
    if (a mod 2 = 0) and (a div 2 >= b) then begin
      writeln(a, ' : 2 = ', a div 2);
      a := a div 2
    end
    else begin
      writeln(a, ' - 1 = ', a - 1);
      a := a - 1;
    end;
  until a <= b;
end.

Ответить

Другие вопросы из категории

Укажите значения переменных K, L, M, N, при которых логическое выражение (¬(M V

L) /\ K) ((¬K /\¬M) \/ N)

ложно. Ответ запишите в виде строки из четырех символов: значений переменных K, L, M и N (в указанном порядке). Так, например, строка 1101 соответствует тому, что K=1, L=1, M=0, N=1.

Помогите построить блок-схему для программы Pascal:

var
n, i, j: integer;
begin
read(n);
for i := 1 to n - 1 do
for j := i to n - 1 do
if i * i + j * j <= n then
writeln(i,'^2 + ',j,'^2 = ',i * i + j * j);
end.

Читайте также

Точка задана своими координатами. Определить, принадлежит ли точка заданной области (включая границу). Формат входных данных Во входном файле записаны два

вещественных числа - координаты точки . Формат выходных данных В выходной файл необходимо вывести или в зависимости от ответа на вопрос задачи.

Примеры: Вход -3 2 Выход Yes

Задача А Четные

N-Factorial - это произведение всех чисел от 1 до N.Для заданного числа N определите,сколько нулей в конце десятичной записи.
Формат входных данных

Автомат получает на вход пятизначное десятичное число. По полученному числу строится новое десятичное число по следующим правилам.1.Вычисляются два числа

- сумма первых трёх цифр и сумма последних трёх цифр.2.Полученные два числа записываются друг за другом в порядке не убывания (без разделителей).Пример.Исходное число:15177.Поразрядные суммы: 7 ,15.Результат: 715.Определите, сколько из приведенных ниже чисел могут получиться в результате работы автомата.2626 2618 2624 2628 2826 2426 1826 610.В ответ запишите только количество чисел ПОМОГИТЕ ПОЖАЛУЙСТА!!!!!!

Дано два натуральных числа N и M.

Написать программу для определения
наименьшего из чисел, составленных из цифр данных чисел. Незначащих
нулей в найденном числе быть не должно.

Формат входных данных:



Вы находитесь на странице вопроса "1)По данному числу n вычислите сумму 2(1-1/3+1/5-1/7+...+(-1)n/(2n+1)). Формат входных данных: Вводится одно число n, не превосходящее 100000.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.