Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

С ПОМОЩЬЮ ПАСКАЛЯ

5-9 класс




1.Найти сумму всех нечётных трёхзначных чисел.

2. Дано натуральное число n.
Сколько цифр в числе n?

Tatka34 29 янв. 2015 г., 5:13:36 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Siadkvfhvsdej
29 янв. 2015 г., 6:03:10 (9 лет назад)

var i,s:integer;
begin
i:=101;
while i<1000 do
  begin
  s:=s+i;
  i:=i+2
  end;
writeln('Ответ: ',s)
end.

var n,x:integer;
begin
write('Введите число: '); 
readln(n);
while n>0 do
   begin
   n:=n div 10;
   x:=x+1
   end;
writeln('Цифр: ',x)
end.

var x,y,z:integer;
begin
for x:=0 to 100 do
   for y:=0 to 100 do
     for z:=0 to 100 do
       if (x+y+z=100) and (10*x+5*y+0.5*z=100) then
             writeln('быков:',x,' коров:',y,' телят:',z);
end.

Ответить

Читайте также

Помогите, с помощью паскаля надо сделать следующее:

Составить программу, решающую следующую задачу: дано трехзначное число. В нем зачеркнули первую цифру слева и приписали ее справа. Вывести полученное число.
Так же:
Составить программу, решающую следующую задачу: дан номер некоторого года (целое положительное число). Определить соотв-щий ему номер столетия, учитывая, что, к примеру, началом 20го столетия был 1901 год. Сам то я знаю как решать, но не смогу записать это в паскаль!

Помогите решить задачи с помощью Паскаля:

1. В массиве все отрицательные элементы переместить в начало массива, а остальные в конец с сохранением порядка следования.
2. Дана последовательность целых чисел, среди чисел есть одинаковые, создать массив различных чисел последовательности и полученный массив отсортировать по возрастанию.

Решить задачи с помощью Паскаля:

1. Заполнить массив из 10 элементов случайными числами в интервале [0..100] и отсортировать его по последней цифре.
2. Заполнить массив из 10 элементов случайными числами в интервале [0..100] и отсортировать первую половину по возрастанию, а вторую- по убыванию. Здесь решать лучше методом выбора.



Вы находитесь на странице вопроса "С ПОМОЩЬЮ ПАСКАЛЯ", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.