Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Составьте программу, определяющую максимальный элемент и его индексы матрицы А размерами MxN(паскаль)

10-11 класс

НастяАнастасия2002 04 дек. 2014 г., 5:45:14 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Ridzi87
04 дек. 2014 г., 6:36:29 (9 лет назад)

Смотри на скриншот я сделал просто не хочу чтоб форматировка текста портилась.Все работает!
const n=3;m=4;
var a:array [1..n,1..m] of integer;    i,j,k,max:Integer;    ind:array [0..1] of Integer=(1,1);
begin 
Randomize; 
 for i:=Low(a) to High(a) do 
 for j:=Low(a) to High(a[1]) do 
   a[i,j]:=Random(100); 
for i:=Low(a) to High(a) do 
  begin   
  writeln;   
for j:=Low(a) to High(a[1]) do 
 write(a[i,j]:3); 
 end; 
 max:=a[1,1]; 
 for i:=Low(a) to High(a) do   
for j:=Low(a) to High(a[1]) do
    if a[i,j]> max then   
  begin 
     max:=a[i,j];   
    ind[0]:=i;     
  ind[1]:=j;     
end;     
writeln; 
Writeln(' Max element: ',max);
 Write(' Index: '); 
 for i:=0 to 1 do 
 write(ind[i],' ');
 Readln;
end. 

Ответить

Другие вопросы из категории

Нужна математическая модель решения задачи!!!

Торговое предприятие ООО «Электрон» осуществляет рознич+ную продажу бытовых электроприборов и средств вычислительнойтехники (СВТ). Для продвижения товара на рынок предприятиеорганизует рекламную кампанию, на проведение которой формиру+ется рекламный бюджет в зависимости от объема продаж и показате+ля отчислений на рекламу. Данные, на основе которых выполняетсярасчет рекламного бюджета предприятия, приведены в табл. 1 и 2.

Запишите числа в десятичной системе счисления

11011 в троичной
423,1 в пятеричной
2А,8 в шестнадцатиричной

Помогите составить алгоритм:Помогите составить алгоритм: Требуется рассчитать необходимое кол-во рулонов обоев для оклейки комнаты.Заданы параметры

комнаты а,b,h.Заданы параметры рулонов обоев длина l,ширина-d,считаем что S окон и дверей составляет 15 % от площади стен.

Читайте также

1.Составить программу, которая увеличивает каждый элемент настоящей таблице х [1 .. 10] на 1. 2. составить программу, замены положительных

элементов настоящей таблице х [1 .. 10] на 0.

3.составить программу, замены отрицательного элементов настоящей таблице х [1 .. 10] на их квадрат.

4.составить прогрумму, которая увеличивает на 2 все элементы настоящей таблице х [1 .. 10], которые больше 10.

помогите составить программу!пожалуйста!!!!ооочень надо

ракета запускается с земли со скоростью V(км час) в направлении движения земли по орбите вокруг солнца. составить программу,определяющую результат запуска ракета в зависимости от скорости V.
Известно,что при V16,4 ракета покинет солнечную систему.

Даны три одномерных массива. Упорядочить их по возрастанию элементов. Составить программу проверки, сколько раз повторяется заданное число в каждом

массиве. Результаты сохранить в одномерном массиве и элементы массива отсортировать по возрастанию Даны три одномерных массива. Упорядочить их по возрастанию элементов. Составить программу проверки, сколько раз повторяется заданное число в каждом массиве. Результаты сохранить в одномерном массиве и элементы массива отсортировать по возрастанию

Составить программу на языке Паскаль: 1)Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2)В массиве М из 10 целых

чисел найти количество элементов равных 3. 3)В массиве из 8 целых найти номер массива с наибольшим значением. 4)В массиве из 12 целых чисел найти количество и сумму элементов, расположенных до максимального элемента. 5)Для массива из 15 вещественных подсчитать количество элементов массива меньших суммы первого и последнего элементов массива.



Вы находитесь на странице вопроса "Составьте программу, определяющую максимальный элемент и его индексы матрицы А размерами MxN(паскаль)", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.