Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

составьте алгоритм, переводящий графического исполнителя в угол поля из любого исходного положения

10-11 класс

Dianfilatova20 13 окт. 2013 г., 6:55:39 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Azatyan777
13 окт. 2013 г., 8:37:06 (10 лет назад)

нц
пока сверху свободно - вверх,
кц
нц
пока слева свободно - влево
кц

Ответить

Читайте также

Помогите составить алгоритм!

Составьте алгоритм(в паскале\на алгоритмическом языке), в котором вычисляются четыре величины: средние температуры зимних месяцев, весенних месяцев, летних месяцев, осенних месяцев.

1. Составьте алгоритм вычисления суммы квадратов цифр,заданного трехзначного числа.

2.Составить алгоритм вычисления разности кубов цифр, заданного восьмизначного числа.
3. Для заданного действительного числа К вычислить значение произведения
(99/k^3-98)*(97/k^3+96)*(95/k^3-94)*...*(3/k^3+2)

1. Составить описание ( алгоритм ) создания архива данных.

Извлечение данных из архива
2. Составить алгоритм записи информации на компакт-диски различных видов.
Организация информации на компакт-диске с интерактивным меню.

Ребята,срочно помогите!)Даю 100 баллов.Составить алгоритм решения задачи на языке C++ . В отчете предоставить три программы с разными операторами

цикла (do ...while, while, for). В алгоритме и программе массивов не использовать.

Я здесь набросал все ,что мог, помогите доработать, написать до конца все эти операторы в одну программу,не получается.

#include <iostream>
#include <cstdlib>
#include <conio.h>
#include <math.h>

using namespace std;
int main()
{
float a,z,xn,xk,dx,R,max,min; float count=0,x;
a = 2.94;xn = 1.5;xk = 5.5;dx = 0.4;
while (xn <= xk)

for (x >= xn; x <= xk; x+=dx, dx = dx + 0.4)
{
do
{
z = a*pow((a*x*x*x*x*x*x*x/cos(a*a*a)+1,31),(1/5));
printf("X = %10f, Z = %10f \n", x, z);
dx = dx + 0.4;
}
while (x <= xk);
return 0;
}
{
max = x;min = z;
if (x > max) max = x;
if (z < max) min = z;
if (count > 2) count = 0;
if (count == 2) printf("X = %10f, Z = %10f \n", x, z);
count=0;
}
cout<<"max="<<max<<"\t min="<<min<<"\n";
cout<<"R="<<min-max<<"\n";
system("PAUSE");
return 0;
}

1. Линейный алгоритм.



Составить алгоритм вычисления
площади поверхности цилиндра S= 2*π*r(h+r).






Вы находитесь на странице вопроса "составьте алгоритм, переводящий графического исполнителя в угол поля из любого исходного положения", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.