Статистика
Всего в нашей базе более 4 327 657 вопросов и 6 445 963 ответов!

решите пожалуйста задачуу на програмирование паскаль. Даны 4 числа. Найти среднее арифметическое этих чисел и сравнить с максимальным из них. Если

5-9 класс

оно(средн. числ.) больше,то вывести фразу "yes", если нет то "no"..

Forever111 20 апр. 2015 г., 16:47:58 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Sokolvla
20 апр. 2015 г., 18:45:06 (8 лет назад)

program zadacha1;

uses crt;

var 

begin;

clrscr;

writeln ('введите 4 числа');

readln (a,b,c,d);

i:=(a+b+c+d)/4;

if a>b then 

g:=a    

           else

g:=b

if g>c then 

g:=g

           else

g:=c;

if g>d then

g:=g

           else

g:=d;

if i>g then

writeln('yes');

          else

writeln('no');

readkey;

end.

Ответить

Читайте также

Плиз срочно надо.1)Найдите правильную на языке паскаль запись выражения

19(16,3+7,7).а)19(16.3+7.7),в)19*(16.3+7.7).д)19(16,3+7.7).с)19*(16.3+7.7).2)Найдите правильную на языке паскаль записы выражения \frac{34,5+24,5}{15y}.а)34.5+24.5/15у в)(34.5+24.5)/15у с)(34.5+24.5)15*у.д)(34.5+24.5)/(15*у).3)Вычислите длину окружности и площадь круга одного и того же заданного радиуса R.4)Даны два числа.Найдите среднее арифметическое кубов этих чисел и среденее геометрическое модулей этих чисел.Два последних номера там нужно написать программу,программу присылать на листочке

помогите решить задачи по информатике (на уровне знаний 7 класса) с помощю PascalABC

1. Дано 2 числа найти модуль разности этих чисел увеличенный в 5 раз.
2. Дано 4 значное число поменять местами 1 и 2 цифру местами
3. Дан диаметр круга найти его площадь (формула S=п*R).
Я примерно знаю как писать но всеровно нуждаюсь в помощи
Мои мысли:
program z1;
uses crt;
var ... : integer;
begin
дальше всё в тумане
буду рад за решённые 1 или 2 задачи

решите пожалуйста задачи на языке pascal abc net.

f3.
Дано целое число. Если оно является положительным, то прибавить к нему 1; если отрицательным, то вычесть из него 2; если нулевым, то заменить его на 10. Вывести полученное число.
f5.
Даны три целых числа. Найти количество положительных и количество
отрицательных чисел в исходном наборе.
f15.
Даны три числа. Найти сумму двух наибольших из них.



Вы находитесь на странице вопроса "решите пожалуйста задачуу на програмирование паскаль. Даны 4 числа. Найти среднее арифметическое этих чисел и сравнить с максимальным из них. Если", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.