Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

Найти сумму N чисел натурального ряда кратных 4, начиная с K>0, N>0, N и K вводятся с клавиатуры.

10-11 класс

Написать программы на паскале по 3-м циклам.

RAYU 09 апр. 2017 г., 17:11:18 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Amazonkar
09 апр. 2017 г., 19:32:47 (7 лет назад)

program Project1;  
uses   Crt;  
var   k, summa : Word;  
 n, i : Byte;
  begin  
 Clrscr;  
Write('Input k= ');
Readln(k);  
write('Input n= ');
Readln(n);  
summa := 0;
  i := 1;  
while ((i <= n)) do  
begin    
if ((k mod 2) = 0) then  
  begin      
summa := summa + k;      
 Inc(i);  
  end;    
 Inc(k);  
end;  
Writeln('Summa= ',summa);  
Readln;
end.


Ответить

Другие вопросы из категории

Помогите, пожалуйста, С++

1. Сформировать список из натуральных
чисел. Удалить из списка отрицательные элементы.
2. Сформировать список из
натуральных чисел. Удалить из списка все элементы, большие 50-ти.

Решить задачу в Паскале

"Ввести с клавиатуры 15 элеметов символьного массива. Заменить все цифры на "звёздочки", а все "пробелы" на знаки подчёркивания. СРОЧНО!!! Жду верного решения :) спасибо заранее

помогите решить СРОЧНО!!!

Читайте также

Язык "Паскаль АВС" 1.Среди двухзначных чисел найти количество четных чисел. 2. Среди двухзначных чисел найдите те числа, у которых первая цифра четная.

3. Среди двухзначных чисел найдите те числа, которые кратны 3 и 4. 4. Среди трехзначных чисел найдите те, у которых все цифры равны. 5. Найдите среди трехзначных чисел симметричные числа. 6. Найдите среди четырехзначных чисел симметричные числа. 7. Найдите все трехзначные числа такие, что сумма цифр равна А, а само число делится на В. А и В вводятся с клавиатуры. 8. Найдите все трехзначные числа такие, которые при увеличении на 1 делятся на 2, при увеличении на 2 делятся на 3, при увеличении на 3 делятся на 4, при увеличении на 4 делятся на 5. 9. Найдите количество трехзначных чисел, сумма цифр которых равна А, а само число заканчивается на В, А и В вводятся с клавиатуры. 10. Найдите все трехзначные числа, у которых сумма крайних цифр равна сумме средних цифр, а само число делится на 6 и 27. 11.Найдите все трехзначные числа, которые при делении на 2 дают остаток 1, при делении на 3-остаток 2, при делении на 4-остаток 3, само число делится на5. 12. Найдите все четырехзначные числа, в которых есть две одинаковые цифры. 13. Найдите сумму всех чисел из промежутка от А до В, кратных 13 и 5, А и В вводятся с клавиатуры. 14. Найдите все симметричные четырехзначные числа. 15.Найдите все трехзначные числа, которые состоят из различных цифр, а их сумма равна А.

помогите решить.паскаль1)найти сумму целых двузначных чисел.

2)найти произведение целых чисел от 3 до n

нужна программа на языке программирования Pascal.

Дана матрица А[8,8] четных чисел натурального ряда (от 2 до 128).
1)Заполнить и записать матрицу.
2)Определит число элементов больших 18 и меньших 60. заменить их на 0.затем записать получившуюся матрицу.
3)Определить произведение главной диагонали и вывести эти элементы на экран.
4)Реализовать определение суммы элементов любого столбца.
Спасибо.

Помогите пожалуйста. Не могу понять как решить.

Вычислить сумму корней квадратных первых N чисел натурального ряда.

Входные данные:Во входном потоке записано единственное целое число N (0 < N <= 100).



Вы находитесь на странице вопроса "Найти сумму N чисел натурального ряда кратных 4, начиная с K&gt;0, N&gt;0, N и K вводятся с клавиатуры.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.