Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

И еще пожалуйста) P=sin(sqrt(abs(x)))*sin(sqrt(abs(2x)))*...*sin(sqrt(abs(n*x)))

5-9 класс

Pavvi 29 июля 2013 г., 19:37:59 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Platosha123
29 июля 2013 г., 21:49:07 (10 лет назад)

var

  P, pr, x: real;

  i, n: integer;

 

begin

  P:= 1;

  writeln('Введите n');

  readln(n);

  writeln('Введите x');

  readln(x);

  for i:= 1 to n do

  begin

    pr:= sin(sqrt(abs(i * x)));

    P:= pr * P;

  end;

  writeln('P = ', P : 0 : 5);

end.

    

       

Ответить

Читайте также

Мы эту тему проходим бегло, а книги про Pascal у меня нет, так что помогите.

Записать в виде обычной математической формулы
1) y:=2*sin(x)*sqrt(x+sqrt(abs(x)))
2) y:=sqrt(sin(x)+sin(sqrt(x)))
3) y:=sqrt(abs(x-1)+sqrt(sin(x)))


1. Язык программирования Pascal создал:

a. Н. Вирт

b. Б. Паскаль

c. М. Фортран

d. Правильных ответов нет

2. Линейная структура построения программы подразумевает

a. Неоднократное повторение отдельных частей программы

b. Последовательное выполнение всех элементов программы

c. Выполнение лишь нескольких, удовлетворяющих заданному условию частей программы

d. Верного ответа нет

3. Оператор присваивания имеет вид:

a. =

b. :=

c. =:

d. Верного ответа нет

4. Команда CLRSCR служит для

a. ожидания нажатия клавиши

b. ввода данных с экрана

c. очистки экрана

d. верного ответа нет

5. раздел VAR служит

a. Для описания используемых переменных

b. Для описания величин

c. Для описания выражений

d. Верного ответа нет

6. Переменные – это:

a. величины, которые могут менять свое значение в процессе выполнения программы

b. величины, которые не могут менять своего значения в процессе выполнения программы

c. обозначают строки программы, на которые передается управление во время выполнение программы

d. Верного ответа нет

7. Правильная строковая запись выражения

a. x-х***3/abs x + sin (x)

b. x-x*x*x/abs (x) +sin (x)

c. x-(x*x*x)/abs (x) +sin (x)

d. Верного ответа нет

8. целочисленное деление можно выразить следующей функцией:

a. A mod B

b. A div B

c. Abs (A)*B

d. Верного ответа нет

9. математическое выражение х2-7х+6 можно записать:

10. выражение на паскале

(abs (x)-abs(y))/(1 + abs (1/s)) можно записать:

11. раздел операторов начинается служебным словом:

a. VAR

b. INTEGER

c. BEGIN

d. Верного ответа нет

12. ввод данных с клавиатуры осуществляется с помощью оператора:

a. WRITE, WRITELN

b. READ, READLN

c. PROGRAM

d. Верного ответа нет

13. вывод данных на экран осуществляется с помощью оператора:

a. WRITE, WRITELN

b. READ, READLN

c. PROGRAM

d. Верного ответа нет

14. чему будет равно значение переменной М в результате выполнения серии операторов
N:=5;

Y:=2;

M:=N/5+3*Y*N

15. тип переменных REAL это:

a. целочисленный тип

b. логический тип

c. натуральный тип

d. верного ответа нет



«Введение в ЯП ПАСКАЛЬ, Линейные алгоритмы».

Вариант №2

Какие значения чисел:

0.85Е2, -5.7Е-3, 0.1Е4?

Пусть а=245, b=-435, c=35.126. Что будет выведено на экран после выполнения следующих команд:

writeln (‘a’, b, ‘c’); write (‘c=’,c:8:1);

write (‘b= ‘, b:6); writeln ((a+c):9:3, b:4)?

Запишите по правилам языка Паскаль такие выражения:

a)

b)

Вычислить значения выражений:

Round(frac(6.9));

20 mod 6 * 3;

sqrt(trunc(0.5)).

Записать выражения в общепринятой форме:

(-3ab+sqr(b-4*a*c))/sqrt(2*a);

(sqrt(abs(a-b))*sqr(a+b).

Если у – вещественная переменная, а х – целая, то какие из следующих операторов присваивания правильные, а какие нет и почему?

a) y:= y * 2; в) х:= х mod 3 + х*cos(0);

б) x:=trunc(y); г) x:= y+1.



Вы находитесь на странице вопроса "И еще пожалуйста) P=sin(sqrt(abs(x)))*sin(sqrt(abs(2x)))*...*sin(sqrt(abs(n*x)))", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.