Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

№1

10-11 класс

Требовалось написать программу, которая определяет, имеется ли среди введенных с клавиатуры положительных целых чисел а и Ь хотя бы одно четное. Была написана следующая программа:

•​ var a, b: integer;

•​ begin

•​ readln(a, b);

•​ a := a mod 2;

•​ if a > 0 then b := b mod 2;

•​ if b > 0 then

•​ writeln ('четных чисел нет')

•​ else

•​ writeln ('четное число есть');

•​ end.

Доработайте эту программу таким образом, чтобы задача решалась верно.

№2

С клавиатуры вводится трёхзначное число. Нужно вывести ответ «Да», если все его цифры четные, и ответ «Нет» в остальных случаях. Если введено не трёхзначное число, должно быть выведено сообщение «Неверное число».

София190 15 сент. 2013 г., 9:37:47 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Vicnkasha
15 сент. 2013 г., 10:14:06 (10 лет назад)

uses crt; 
var a, b: integer; 

Ответить

Другие вопросы из категории

Var n,s:integer;

Begin
N:=0;
S:=0;
While s<=35 do begin
N:= n+1;
S:=s+4
End;
Write(n)
End.
Решите пожалуйста, надо с решением.

Access

1. Что такое запросы?
2. Что такое отчеты?
3. Что такое формы?
4. Что такое бланк запроса?

Читайте также



Вы находитесь на странице вопроса "№1", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.