Статистика
Всего в нашей базе более 4 327 657 вопросов и 6 445 963 ответов!

Посчитайте количество десятичных натуральных чисел, не превосходящих 63, при записи которых в четверичной системе счисления результат будет

5-9 класс

заканчиваться на две одинаковые цифры —--- ответ 15... главное решение)) и подробное обьяснение, я слоупок в этом -_-

Fomik97 04 нояб. 2013 г., 15:29:17 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Marina111222
04 нояб. 2013 г., 18:03:01 (10 лет назад)

 Суть алгоритма:

0) счётчик  одинаковывых цифр   устанавливаем в с:=0; 

 

 1) Организуем цикл от 1 до 63 

 2) Каждое из этих чисел переводим в 4-ичную систему счисления 

3) Переводим 4-ичное число в  строку.

4) Если длина строки =2 символа то сравниваем второй и первый символ 

                      если равны то c:=c+1;

5)  Если длина строки =3 символа то сравниваем второй и третий символ 

                      если равны то c:=c+1; 

6) Печать результата 

 7) Выход

 

  Program Count;

 Uses Crt;
 var i,c,l:integer;
 s,s2:string;

Function FromDec(n:string; radix: longint):string;
var S:string;
i,m:longint;
const
digit: string[36]='0123456789ABCDEFGHIJKLMNOPQRSTUVWXYZ';
begin
m:=0;
for i:=1 to length(n) do
m:=m*10+(Ord(n[i])-48);
S:='';
repeat
s:=digit[(m mod radix)+1]+s;
m:=m div radix;
until m=0;
FromDec:=s;
End;

function IntToStr(I: Longint): String;
var S: string[11];
begin
Str(I, S);
IntToStr := S;
end;


{Основная программа}
begin
clrscr;
c:=0;
for i:=1 to 63 do
begin
s2:=IntToStr(i);
s:=FromDec(s2,4);
l:=length(s);
if (l=2) then
if (s[2]=s[1]) then c:=c+1;

if (l=3) then
 if (s[l]=s[l-1]) then c:=c+1;
end;
writeln('Количество одинаковых:',c);
 readkey;
end.

 

 

 

 

Ответить

Другие вопросы из категории

Написать програму для Паскаля :Дан линейный массив,содержащий положительные и отрицательные целые числа ,n=10.Создать новый массив, в котором

содержатся только положительные элементы из исходного масива ,упорядочить этот новый массив по возрастанию.

некий чёрный ящик можно настроить на программу преобразования информации.В результате изучение его работы были получены протоколы

испытаний.Определите тип выходной информации (числовая,текстовая) и правило преобразования информации

Читайте также

Выведите все точные квадраты натуральных чисел, не превосходящие данного числа N. Формат входных данных Задано единственное число N. Формат выходных

данных Необходимо вывести все точные квадраты натуральных чисел, не превосходящие данного числа N.

Помогите решить информатику.

1. Дано: x=ED(16), y=F7(16). Какое из чисел x, записанных в двоичной системе, удовлетворяют условию x-1<x<y+1
2.Чему равно значение суммы 1111(2)+777(8)+99(10)+F(16)
3.Найдите значение выражения А3(16)+24(8)*101(2). Результат запишите в восьмеричной системе счисления.
4. Найдите значение выражения ЕС(16)-26(8)*10(10). Результат запишите в шестнадцатеричной системе.
5. Известно, что 133(t)=111(2) и 283(t)=456(7). Найдите основание системы счисления t.
6. Укажите через запятую в порядке возрастания все числа, не превосходящие 31(10), запись которых в восьмеричной системе счисления оканчивается на 22. Ответ запишите в двоичной системе.

Написать программу в паскале: Дано натуральное n. вычислить: 1 + 1/2 + 1/3 + 1/4 + ... + 1/n.

Задано натуральное число N. Найти количество натуральных чисел, не превосходящих N и не делящихся ни на одно из чисел 2,3,5.

Напишите программу, которая подсчитывает количество двузначных чисел в заданной последовательности натуральных чисел.Программа получает на вхо

д количество чисел в последовательности, а затем сами числа.Количество чисел не превышает 1000. Введённые числа не превышают 30 000.Программа должна вывести одно число – количество двузначных чисел в заданной последовательности натуральных чисел.

Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в

последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4. Количество чисел не превышает 1000. Введённые числа не превышают 30 000.



Вы находитесь на странице вопроса "Посчитайте количество десятичных натуральных чисел, не превосходящих 63, при записи которых в четверичной системе счисления результат будет", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.