Статистика
Всего в нашей базе более 4 327 657 вопросов и 6 445 963 ответов!

Program tutor;

5-9 класс

var
x: byte;
const
P = 12;
A = 6;
B = 10;
C =11;
begin
X:= (P*(P-A)*(P-B)*(P-C))^(1/2);
Writeln(x);
end.

Что в этой программе не так? Я хочу извлечь корень из х, а программа пишет "ОШИБОЧНЫЙ ИДЕНТИФИКАТОР".

Program tutor;
var
X, Z: byte;
const
P = 12;
A = 6;
B = 10;
C =11;
begin
X:= (P*(P-A)*(P-B)*(P-C))^(1/2);
Z:=sqrt(X);
Writeln(x,z);
end.

И через "sqrt"- оператор не хочет выдавать корень из Х. Что я не так делаю? подскажите.

Ladanpol 21 дек. 2014 г., 14:47:08 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Darya555111
21 дек. 2014 г., 16:11:06 (9 лет назад)

Если не ошибаюсь, то X и Z являются типа byte. Требовать от переменных этого типа извлечение корня неправильно. Так как это по определению целые положительные числа, размером до 256. От переменной, из которой извлекают корень, требуется тип значения - действительное число. Так что лучше сразу объявить эти две переменные типа double (похоже так в Паскале).  

В первом же случае лучше извлечь корень с помощью операции sqrt. Снова, если не ошибаюсь, операция возведения в степени в Паскале довольно трудоемка что ли. Она определяется через exp и ln. Так что лучше не заморачиваться, а воспользоваться оператором  sqrt.

Ответить

Другие вопросы из категории

1) Считая, что каждый символ кодируется одним байтом, определите, чему равен информационный объем следующего высказывания Жан-Жака (пробел-тире-пробел):

Тысячи путей ведут к заблуждению, к истине - только один.
1) 92 бита 2) 220 бит 3) 456 бит 4) 512 бит

2) Сколько бит информации содержит сообщение объемом 8 Мб?

3) Информационное сообщение объемом 16 кбайт передается со скоростью 1024 бит/сек. За сколько секунд будет передано данное сообщение?

4) Объем текста имеет 30 килобайтов, на каждой странице текста 30 строк по 64 символа на каждой. Один символ имеет объем 8 бит. Чему равно количество страниц в тексте?

5) Модем передает данные со скоростью 64000 бит/с. Передача текстового файла заняла 1,5 мин. Определите, сколько страниц содержал переданный текст, если известно что он был представлен в 16 битной кодировке Unicode, а на одной странице 400 символов

Ответы с решением, пожалуйста

Подскажите что будет нарисовано после выполнения Чертёжником алгоритма Использовать чертёжник

Поднять перо
сместить в точку (1,1)
опустить перо
сместиться в точку (1,2)
сместиться в точку (5,2)
сместиться в точку (5,1)
поднять перо
сместиться в точку (4,2)
опустить перо
сместиться в точку (4,5)
сместиться в точку (3,5)
сместиться в точку (2,4)
сместиться в точку (2,2)

1.Составить программу, которая определяет номера позиций символа","

2. Составить программу, которая позволяет заменить все гласные символом "*"

Читайте также

Прошу вас, помогите! Решается оценка!!! Найдите ошибки в программе 1)Program z1; var a:integer; begin a:=10; while

a<5 do

writeln(a);

a:=a+1;

End.

2)Program z2;

var a,s:integer;

begin

a:=1; s:=0;

while a<10 do begin

s:=s+a/2;

end;

writeln(s);

end.

Помогите пожалуйстаа!! Определите результат работы программы, написанной на языке Паскаль. 1) program a5 var i, m:

integer;

begin

m:= 0

for i: = 1 to 6 do

m: = m-6

writeln (m)

end.

2) program a6

var i, m: integer;

begin

m:= 0;

for i: = 3 to 7 do

m: = m-6+i;

writeln (m)

end.

Какая структура программы верна. Перечислите и объясните найденные ошибки:

а)
Begin
program MyFirst;
X:= Y+195;
end.
b)
program MyProg
begin
Writeln ('Привет');
end.



Вы находитесь на странице вопроса "Program tutor;", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.