Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

Составить программу для решения задачи: 1)Даны действительные, положительные числа x,y,z. Выяснить, существует ли треугольник с длинами сторон x,y,z. Если

10-11 класс

треугольник, то является ли он равносторонним? 2)Дан одномерный массив. Найти количество смен знака между соседними элементами массива. Программа -Паскаль.

Aisonaku 16 нояб. 2013 г., 2:37:08 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Umida17
16 нояб. 2013 г., 4:40:36 (10 лет назад)

var x,y,z:real;
begin
readln(x,y,z);
if (x<y+z) and (y<x+z) and (z<x+y) then begin
if (x=y) and (y=z) then writeln('Ravnostoronnii') else writeln('Ne ravnostoronnii');
end else writeln('Ne vozmojno sostavit');
end.

 

var a:array[1..10]of integer;
i,sum:integer;
begin
for i:=1 to 10 do readln(a[i]);
for i:=1 to 9 do begin
if (a[i]>0) and (a[i+1]<0) then sum:=sum+1;
if (a[i]<0) and (a[i+1]>0) then sum:=sum+1;
end;
writeln(sum);
end.

Ответить

Другие вопросы из категории

Что выведет данная программа? program p1;

var Z:integer;
function f (n:byte):longint;
begin
if n=0 then f:=1
else f:=(2*n)*f(n-1); end;
begin
z:=f(5); writeln (z);end.

5 плиз вовлыьыььыьыьвтвё
Напечатать в возрастающем порядке

все трёхзначные числа,в десятичной записи кот. нет одинаковых цифр

Читайте также

1. Составить программу для нахождения наибольшего числа из трех чисел.

2. Составить программу для упорядоченное двух элементов по убыванию.

Разработать программу для решения задачи, ввод данных организовать через рабочий лист MS Excel (Написать код)

Из данного массива А трехзначных чисел записать в массив В элементы, содержащие цифру 5.
Исходные данные на картинке. Заранее Спасибо!

Помогите с задачками в паскале. Даны три положительных числа а, в, с. Проверить будут ли они сторонами треугольника. Если да то

вычислить площадь этого треугольника. Даны два действительных положительных числа х и у. Арифметические действия над числами пронумерованы (1 - сложение, 2 - вычитание, 3 - умножение, 4 - деление). Составить программу, которая по выведенному номеру выполняет то или иное действие над числами.



Вы находитесь на странице вопроса "Составить программу для решения задачи: 1)Даны действительные, положительные числа x,y,z. Выяснить, существует ли треугольник с длинами сторон x,y,z. Если", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.