Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Помогите пожалуйста написать программу и блок схему к этому заданию

10-11 класс

Helenanikienko 24 сент. 2014 г., 18:05:01 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Valeasalnikova
24 сент. 2014 г., 18:56:20 (9 лет назад)

var
    x, y, z : Real;
begin 
    Write('x: '); 
    Readln(x);   

    Write('y: '); 
    Readln(y);   

    if x < y then
    begin
        z := exp(ln(abs(x - y))*(1/3));
        if x - y < 0 then z := -z;
    end
    else
        z := sqrt(x - y);

    Writeln(z:0:3);
    Readln;
end.

Ответить

Другие вопросы из категории

Начальнику производственного отдела и необходимо распределить премию в сумме 500 $ между сотрудниками отдела пропорционально их должностным окладам.

Список сотрудников и их оклады представлены в таблице 1.


ФИО сотрудника Оклад,$
Топорков А.Б. 100
Березкин В.Г. 98
Дубова Д.Е. 120
Рябинкин И.К. 105
Вязов Л.М. 89
Ивочкина Л.О. 127

Пожалуйста помогите решить в Excel

Читайте также

написать программу на Assembler

добрый вечер, всем. помогите, пожалуйста, написать программу на Ассемблере.

задание:
Создать программу на языке Ассемблер, что позволяет организовать вычисления над элементами массивов

Объединить два массива 8-битных целых чисел со знаком. Сначала элементы второго затем первого.

заранее огромное спасибо всем!

помогите пожалуйста нужна программа Паскаль вот задача (При каждом переходе через волшебный мост мужик, имеющий b рублей, удваивает эту сумму за счет

капитала черта (а рублей), стерегущего этот мост, после чего он должен уплатить черту дань в размере с рублей. Процесс этот продолжается до полного разорения одного из участников.Сколько будет совершено переходов моста?). вот блок схема пожалуйста сроочноо

программа на C++ в визуальном режиме (есть несколько вариантов кода программы)

доброй ночи, уважаемые программисты и успевающие в учебе студенты. помогите, пожалуйста, написать программу на C++ (в визуальной вкладке).

ВОТ ЗАДАНИЕ:
дано три переменные вещественного типа. если их значения упорядочены по возрастанию или убыванию, то удвоить их; иначе заменить значение каждой переменной на противоположное. вывести значения переменных.


я прикрепила несколько тестовых файлов (блокнот) в которых есть несколько вариантов решение этого задание (то есть коды программ), а вы скажите какой из них лучше всего подходит, а также скажите какие компоненты нужно кинуть на форму-дизайн (то есть какие кнопки, и что на них писать). в этих 3 файлов есть написанный код программы, нужно написать: на какие кнопки что писать и какой вариант решение больше подходит.

заранее огромное спасибо всем за помощь!!!

Помогите, Пожалуйста, с программой Паскаль. Рассмотрим целочисленный массив А[1..N] при N <= 100.

Написать программу, которая вычисляет среднее арифметическое элементов с четными индексами и среднее арифметическое с нечетными индексами.
Ввод: Число N и элементы массива вводятся из Файла.
Вывод: В файл должны быть введены 2 вычисленных значения



Вы находитесь на странице вопроса "Помогите пожалуйста написать программу и блок схему к этому заданию", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.