Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Ввести натуральное n, n целых чисел. Найти максимальное число и его номер. Если чисел несколько, то номер последнего.

5-9 класс

Svit197832 02 нояб. 2015 г., 7:03:34 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Печеня570
02 нояб. 2015 г., 8:49:49 (8 лет назад)

program gt;
var n,i,a,l,max:integer;
begin
read(N);
for i:=1 to n do
begin
read(a);
if(a>=max)then begin
max:=a;
l:=i;
end;
end;
writeln(max,' ',l);
end.

+ 0 -
Vbavrina26
02 нояб. 2015 г., 10:11:05 (8 лет назад)

И блок-схему :3

Ответить

Другие вопросы из категории

Мачеха,уезжая на бал,дала Золушке мешок,в котором были перемешаны мак и просо,и велела перебрать их.Когда Золушка уежзала на бал, она оставила три

мешка:в одном было просо,в другом-мак,а втретьем-ещё не разобранная смесь. Чтобы не перепутать мешки,Золушка к каждому из них прикрепила по табличке:"Мак","Просо","Смесь".Мачеха вернулась с бала первой и нарочно поменяла местами все таблички так,чтобы на каждом мешке оказалась неправильная надпись.Ученик Феи успел предупредить Золушку, что теперь ни одна надпись на мешках не соответствует действительности. Тогда Золушка достала только одно-единственное зёрнышко из одного мешка и,посмотрев на него, сразу догадалась, где что лежит. Как она это зделала?

Читайте также

Помогите написать программы >< Задача 1: Среди целых чисел найти минимальное число, которое больше 20 и делится на 17. Задача 2:

Найти максимальное натуральное число меньше 5000, которое делится нацело на 39.

Задача 3: 1 марта в банк положили 1000 руб. Каждый месяц вклад увеличивается на 2% от имеющейся суммы.

а) за какой месяц величина процентной надбавки превысит 30 руб.?

б) через сколько месяцев размер вклада превысит 1200 руб.? Заранее спасибо)

1.Дан массив целых чисел, найти среднее арифметическое всех элементов массива.

2. Дан массив целых чисел,найти количество отрицательных элементов массива.
3. Дан массив целых чисел,найти количество чётных чисел в массиве.

Напишите программу, которая в последовательности натуральных чисел определяет максимальное число, кратное 5. Программа получает на вход количество чисел в

последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 5.
Количество чисел не превышает 1000. Введенные числа не превышают 30 000.
Программа должна вывести одно число - максимальное число, кратное 5.

Напишите программу, которая в последовательности натуральных чисел определяет максимальное число, оканчивающееся на 3. Программа получает на вход

количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, оканчивающееся на 3. Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число – максимальное число, оканчивающееся на 3. Пример работы программы: Входные данные Выходные данные 3 23 13 23 3

Напишите программу , которая в последовательности натуральных чисел определяет максимальное число , кратное 5. Программа получает на вход количество

чисел в последовательности , а затем сами числа . В последовательности всегда имеется число , кратное 5. Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число – максимальное число , кратное 5



Вы находитесь на странице вопроса "Ввести натуральное n, n целых чисел. Найти максимальное число и его номер. Если чисел несколько, то номер последнего.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.