Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

СРОЧНО!Напишите задачу в паскаль.

5-9 класс

1.дано натуральное число определить сумму кубов его цифр
2. дано натуральное число определить его первую цифру

Morgan911 28 февр. 2017 г., 20:04:17 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
ане444ка
28 февр. 2017 г., 21:04:51 (7 лет назад)

1.
var 
  a, s, cifra: integer;
begin
  s:= 0;
  writeln('Введите натуральное число');
  readln(a);
  while a > 0 do
  begin
    cifra:= a mod 10;  //Определяем очередную цифру числа
    s:= s + cifra * cifra * cifra;  //Прибавляем к значению s цифру в кубе
    a:= a div 10;  //целочисленное деление числа на 10 (отсекаем текущую цифру)
  end;
  writeln('Сумма кубов цифр числа:  ', s);
end.
2.
var
  a: integer;
begin
  writeln('Введите натуральное число');
  readln(a);
  while a > 9 do  {Определяем первую цифру числа путем отрезания цифр числа, пока число не станет однозначным. Полученное число и будет первой цифрой}
    a:= a div 10;
  writeln('Первая цифра числа:  ', a);
end.
    

Ответить

Другие вопросы из категории

1.заполните одномерный массив B1 размерностью в N(< 30 задает пользователь при выполнении программы) элементов так, чтобы каждый элемент с четным

номером был равен половине своего номера, а каждый элемент с нечетным номером - количеству элементов в массиве. сформированный массив вывести на экран в столбик.
2.а) найдите среднюю температуру за неделю. (температура была: -5; -3; -7; -6; -2; -4; -3)
б) сколько дней было выше средней? ниже средней?
3. сформируйте массив BC размерностью 30 элементов случайным образом из диапазона 0 - 50. сформированный массив выведите на экран в строку. подсчитайте сумму всех четных элементов массива и отдельно сумму элементов имеющих четные индексы. выведите результаты подсчета на экран. замените элементы равные своему индексу на самый большой элемент массива, если таковые имеются. получившийся массив выведите на экран в столбик. отсортируйте получившейся массив по убыванию.

Читайте также

надо решить задачу по паскалю) "Чтобы избавиться от простуды необходимо 20 таблеток колдрекса или 30 таблеток аспирина. Сколько порций эскимо можно

купить на эти деньги?"
напишите пожалуйста как составить это в паскале) буду благодарна:)

НАПИШИТЕ ПРОГРАММУ В ПАСКАЛЕ, СРОЧНО !!

написать программу, которая вычисляет среднее арифметическое ненулевых элементов массива M[1..100], элементы которого вычисляются по формуле M[i]=sin(i)*cos(i)

и прошу не используйте интернет, а напишите сами по возможности.

Помогите, пожалуйста, очень нужно! Срочно!:( 1) Не используя функцию возведения в квадрат, напишите на языке Паскаль наиболее короткие алгоритмы

вычисления: а) y=x^10 б) y=x^15. Постараться использовать минимальное количество дополнительных переменных. 2) Дана сторона равностороннего треугольника. Найти площадь этого треугольника, его высоты, радиусы вписанной и описанной окружностей. Программу записать на языке Паскаль. 3) Дана величина А, выражающая объём информации в байтах. Перевести А в более крупные единицы измерения информации. Программу записать на языке Паскаль



Вы находитесь на странице вопроса "СРОЧНО!Напишите задачу в паскаль.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.