Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

найти n=ый элемент и сумму ряда Фибоначчи? задача на тему цикл с известным числом повторения

5-9 класс

Lenanesk 01 янв. 2014 г., 2:37:13 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Natashanikto
01 янв. 2014 г., 4:45:13 (10 лет назад)

это если без массива

 

var n,i:integer;

a0,a1,a2,s:real;

Begin

  read(n);

  for i:= 1 to n do begin

    if i<3 then a0:=1

    else a0:=a1+a2;

    s:=s+a0;

    a2:=a1;

    a1:=a0;

  end;

  writeln(a0, s);

End.

Ответить

Другие вопросы из категории

Укажите к каким информационным процесам относится:сьёмка кинофильма размышление телефоный разговор ксерокопирывание ответ ученика на уроке написание

письма кодирыване сообщений написание контрольной работы выставление семестровой оценки ведения дневника фотографирывание ведение записей на уроке показ пантомимы отправка письма

помогите пожалуйста )))
Главный редактор журнала отредактировал статью, и её объём уменьшился на 4 страницы. Каждая страница содержит 32 строки, в каждой строке 64 символа.

Информационный объём статьи до редактирования был равен 1 Мбайт. Статья представлена в кодировке Unicode, в которой каждый символ кодируется 2 байтами. Определите информационный объём статьи в Кбайтах в это варианте представления Unicode после редактирования.

Читайте также

Найти сумму ряда 1+1/2+1/3+...+1/50(for)

Выходные данные :вывести сумму ряда.

составить на Паскале: 1) программу для вычисления суммы ряда S=1+ 1/2+1/3+1/4+..+1/N. Число N вводится с клавиатуры. 2) одноклеточная

амеба каждые 3 часа делиться на 2 клетки. Определить, сколько амеб будет через 3,6,9,12 и 24 часа.

3) дано натуральное числоо N и действительное число Х. Вычислить сумму ряда sin(x)+sin(2x)+sin(3x)+...+sin(Nx).

4) написать программу для вычисления n-ой степени числа А.

помогите, пожалуйста)

ПОЖАЛУЙСТА!ПОМОГИТЕ!СРОЧНО!

Решить задачи на турбопаскале:
1.Дано натуральное число Найти сумму и произведение первых двух чисел.
2.Дано n-значное натуральное число. Правда ли что квадрат произведения цифр числа равняется кубу суммы цифр числа.
3.Составить программу, которая печатает таблицу умножения и сложения натуральных чисел в десятичной системе счисления.

Запросить стороны треугольника и определить,является ли он разносторонним,равносторонним или равнобедренным. Учесть: третья сторона не должна превышать

сумму двух других,иначе треугольник не существует. Задача на тему "Программирование ветвлений на Паскале".

1. Имеется целочисленный массив, состоящий из 15 элементов: a) Найти сумму a[1] и a[7] элементов; b) Найти разность a[9] и a[3] элементов; c) Найти

среднее арифметическое всех элементов массива; d) Найти произведение всех элементов массива.



Вы находитесь на странице вопроса "найти n=ый элемент и сумму ряда Фибоначчи? задача на тему цикл с известным числом повторения", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.