Статистика
Всего в нашей базе более 4 327 657 вопросов и 6 445 963 ответов!

В массиве, состоящем из 10-ти целых чисел, найти количество элементов, больше среднего арифметического элементов этого массива.

10-11 класс

Sania79 13 февр. 2014 г., 1:30:50 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Krava413232
13 февр. 2014 г., 2:04:27 (10 лет назад)

Var a:array[1..10] of real; i,j,m:integer; n:real;
begin
n:=0;
m:=0;
for i:=1 to 10 do
begin
readln(a[i]);
n:=n+a[i];
end;
n:=n/10;
for j:=1 to 10 do
begin
if (a[j]>n) then m:=m+1;
end;
writeln(m);
end.

Ответить

Читайте также

Составить программу на языке Паскаль: 1)Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2)В массиве М из 10 целых

чисел найти количество элементов равных 3. 3)В массиве из 8 целых найти номер массива с наибольшим значением. 4)В массиве из 12 целых чисел найти количество и сумму элементов, расположенных до максимального элемента. 5)Для массива из 15 вещественных подсчитать количество элементов массива меньших суммы первого и последнего элементов массива.

Задание1: В массиве из 100 случайных целых чисел найти максимальный элемент и количество вхождений этого элемента в массив. Задание2: Реализовать

простые операции с матрицами: транспонирование, умножение на число, сложение и перемножение двух матриц. Значения матриц задавать случайным образом, выбор операции предоставлять пользователю.



Вы находитесь на странице вопроса "В массиве, состоящем из 10-ти целых чисел, найти количество элементов, больше среднего арифметического элементов этого массива.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.