Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

найти сумму элементов стоящих на четных местах и элементов стоящих на нечетных местах в массиве: 3,7,-2,11,6,-3,91,-74,10

10-11 класс

лалкапол 18 апр. 2016 г., 1:59:21 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Анфиса8586
18 апр. 2016 г., 4:18:57 (8 лет назад)

var a:array[1..100]of integer;
i,n,s1,s2:integer;
begin
readln(n);
for i:=1 to n do
readln(a[i]);s1:=0;s2:=0;
for i:=1 to n do
if i mod 2=0 then s1:=s1+a[i];
if i mod 2=1 then s2:=s2+a[i];
writeln(s1,' ',s2);
end.

Ответить

Другие вопросы из категории

Как в программе PascalABC.NET вывести символы

из таблицы ASCII?
Например, необходимо оформить вывод данных на экран в виде аккуратной таблицы. Как
описать в программе ввод этих символов: └

Автоматическое устройство осуществило перекодировку текстового сообщения на русском языке, первоначально записанного в Unicode, в кодировку

КОИ-8. При этом информационный объем сообщения уменьшился на 480 бит. Сколько символов в этом сообщении?

Читайте также

Задача Pascal

Найти наименьшие элементы в каждом столбце матрицы Х(5,5) и переписать их в одномерных массив А.В массиве А вычислить сумму элементов,стоящих на четных местах и произведение элементов,стоящих на нечетных местах.Массив А,сумму и произведение вывести на экран

Дана квадратная матрица размера N. Если сумма элементов по главной диагонали больше суммы элементов на побочной диагонали, то заменить элементы стоящие на

четных местах в строке на “ * ”, а элементы стоящие на нечетных местах в строке на ноль.

дано массивы A(N1,N1),B(N2,N2),C(N3,N3). найти в каждой строке исходного массива наименьший элемент и переставить его с элементом стоящим на главной

диагонали. нахождение в каждой строке массива наименьшего элемента и его перестановку с элементом стоящим на главной диагонали оформить в виде подпрограммы

1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы

каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3. Ввести массив с клавиатуры, найти и вывести сумму элементов массива. 4. Ввести массив с клавиатуры, подсчитать, сколько в нем положительных элементов, а сколько отрицательных. 5. В одномерном массиве подсчитать, сколько отрицательных элементов находится на четных местах и сколько положительных на нечетных. 6. Элементы массива вводятся с клавиатуры, заменить в нем все отрицательные элементы их квадратами, а положительные кубами. Вывести на экран исходный и новый массив. 7. Ввести массив с клавиатуры, найти и вывести на экран максимальный и минимальный элементы. 8. Написать программу, которая определяет есть ли в массиве элемент введенный пользователем, подсчитывает их количество и выводит номер первого найденного элемента.



Вы находитесь на странице вопроса "найти сумму элементов стоящих на четных местах и элементов стоящих на нечетных местах в массиве: 3,7,-2,11,6,-3,91,-74,10", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.