Статистика
Всего в нашей базе более 4 327 657 вопросов и 6 445 963 ответов!

Имя входного файла:E.in имя выходного файла E.out Дается.. ... Имя входного файла:E.in имя выходного файла E.out Дается последовательность из N

10-11 класс

чисел.найдите максимальное произ.среди всех пар этих чисел.

Bolotova03 27 апр. 2014 г., 7:29:30 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Ирина995
27 апр. 2014 г., 10:22:37 (9 лет назад)

Program Pr1;
uses crt;
var mas:array[byte] of integer;
fl1,fl2:text;
stroka:string;
b,v,c,max,i:integer;
Begin
clrscr;
assign(fl1,'E.in');
assign(fl2,'E.out');
reset(fl1);
readln(fl1,stroka);
close(fl1);
for i:=1 to length(stroka) do val(stroka[i],mas[i],b);
b:=length(stroka);
max:=1;
v:=0;
for i:=1 to b do if mas[i]>v then if mas[i]>max then max:=mas[i]
else v:=mas[i];
c:=max*v;
rewrite(fl2);
writeln(fl2,c);
close(fl2);
end.

 

Ответить

Другие вопросы из категории

СРОЧНО!!! Дан целочисленный массив из 30 элементов, все элементы которого – неотрицательные числа, не превосходящие 10000. Опишите на русском

языке или на одном из языков программирования алгоритм, который находит и выводит минимальное трехзначное число, записанное в этом массиве. если таких чисел нет, нужно вывести сообщение «Таких чисел нет».

объяните решение пожалуйста программу не обязательно писать

Читайте также

Дается последовательность из N чисел. Выведите разницу между максимальным и минимальным элементами последовательности.

Формат входных данных
Первая строка входного файла содержит целое число N (1 <= N <= 100000). В следующей строке задаются N положительных целых чисел, каждое из которых не превышает 100000.

Дано натуральнок K от 1 до 180.Написать программу для определения цифры, которая находится в k-той позиции последовательности 10111213...9899. Формат

входных данных Файл содержит число k-позиция искомой цифры. Формат выходных данных Выходной файл содержит искомую цифру. Пример входных и выходных файлов Task1.in Task1.out 4 1 8 3

Задача Z. Угадай число

Имя входного файла: стандартный ввод
Имя выходного файла: стандартный вывод
Ограничение по времени: 2 секунды
Ограничение по памяти: 256 мегабайт
Это интерактивная задача. В процессе тестирования ваша программа будет взаимодействовать
с программой жюри с использованием стандартных потоков ввода/вывода.
Программа жюри загадала число от 1 до n, цель вашей программы — отгадать его. Для этого
ваша программа сообщает свои догадки программе жюри, а программа жюри отвечает, является
ли загаданное число большим, меньшим или равным сделанной догадке.
Выполнено неравенство 1 ≤ n ≤ 109
. Ваша программа должна сделать не более 30 догадок.
Протокол взаимодействия с программой жюри
Сначала ваша программа должна прочитать из стандартного потока ввода число n. Затем
протокол общения следующий: ваша программа выводит в стандартный поток вывода одну строку,
содержащую число — свою догадку о загаданном числе. Делайте сброс буфера потока вывода после
каждой догадки. Для этого используйте
• flush(output) в паскале или Delphi;
• fflush(stdout) или cout.flush() в С/C++;
• System.out.flush() в Java.
• sys.out.flush() в Python.
После этого программа должна считать из стандартного потока ввода одно число: ответ
программы жюри. Возможны следующие ответы:
• 1 — загаданное число больше последней догадки;
• −1 — загаданное число меньше последней догадки;
• 0 — последняя догадка верна. Считав 0, ваша программа должна завершиться.
Пример
стандартный ввод стандартный вывод
5
-1
1
0
3
1
2

Написать программу для сложения А и В в троичной системе счисления.

Числа А и В хранятся в первой строке входного файла Exemp.in их сумма в троичной системе-в выходном файле Exemp5.out

Заданное число M из диапазона 0.. 109. перевести в

троичную систему счисления . Число M хранится в
входном файле Exch.in, его представление в троичной
системе счисления сохранить в выходном файле
Exch.out.



Вы находитесь на странице вопроса "Имя входного файла:E.in имя выходного файла E.out Дается.. ... Имя входного файла:E.in имя выходного файла E.out Дается последовательность из N", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.