Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

Найти среднее арифметическое всех целых чисел в промежутке от 1 до 100

5-9 класс

камалика 03 янв. 2015 г., 4:45:21 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Karifanlova1
03 янв. 2015 г., 6:44:22 (9 лет назад)

VAR i,s:integer;

Begin

  for i:= 1 to 100 do

    s:= s+ i;

 writeln(s/100);

End.

 

Ответить

Читайте также

1)Напишите программу, которая в последовательности натуральных чисел определяет количество всех чисел, кратных 3 и оканчивающихся на 4. Программа получает

на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность).

2)Найти среднее арифметическое всех целых чисел от a до 200 (значения a и b вводятся с клавиатуры; a>=200);

1.Дан массив целых чисел, найти среднее арифметическое всех элементов массива.

2. Дан массив целых чисел,найти количество отрицательных элементов массива.
3. Дан массив целых чисел,найти количество чётных чисел в массиве.

Даны два целых числа А и В (А < В) . Найти произведение всех целых чисел от А до В включительно.

Входные данные: ввести два целых числа А,В (1 <=А,В<=10).
Входные данные: вывести произведение всех целых чисел от А до В включительно.

Проблема с Паскалем. Мне надо посчитать среднее арифметическое всех отрицательных чисел в массиве из десяти элементов. Я понимаю, как сначала надо

распредилить, какие числа меньше нуля, но как вычислить среднее арифметическое, не зная точное кол-во отрицательных элементов? Желательно написать полной программой. Заранее спасибо с:



Вы находитесь на странице вопроса "Найти среднее арифметическое всех целых чисел в промежутке от 1 до 100", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.