Статистика
Всего в нашей базе более 4 327 657 вопросов и 6 445 963 ответов!

Дано целое число N (> 1). Вывести наименьшее целое K, при котором выполняется неравенство 3K < N, и само значение 3K

5-9 класс

Slavakryt 28 февр. 2015 г., 6:29:04 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Yanochka201426
28 февр. 2015 г., 7:38:01 (9 лет назад)

var
  n, k: integer;

begin;
  read(n);
  k := -10000;
  while(k < 0) do
    k := k - 1;
  writeln('Min: k = ', (k + 1) div 3, ', 3*k = ', k + 1);
 
  k := n div 3;
  if 3 * k >= n then k := k - 1;
  writeln('Max: k = ', k, ', 3*k = ', 3 * k);
end.

+ 0 -
Satbaevb
28 февр. 2015 г., 10:28:29 (9 лет назад)

Program z1;
Var k:integer;
Begin
Readln(k);
Writeln('1');
End.

Ответить

Другие вопросы из категории

Структура БД изменится если

1. добавить/удалить поле
2. отредактировать запись
3. поменять местами записи
4. Добавить запись
5. Удалить запись

Читайте также

Ребята кто разбирается в Pascal ABC помогите пожалуйста Задачи на циклы с параметром 1.Дано вещественное число A и целое число N (> 0).

Вывести A в степени N: An = A•A•...•A (числа A перемножаются N раз). 2.Дано вещественное число A и целое число N (> 0). Вывести все целые степени числа A от 1 до N. 3.Дано вещественное число A и целое число N (> 0). Вывести 1 + A + A2 + A3 + ... + An. ,

Помогите по программе paskal : 1.дано целое число.напишите программу которая уменьшает на 2 модуль этого числа и выводит на экран монитора

результат

2.дано целое число.напишите,программу которая выводит на экран последнюю цифру данного числа,затем возводит ее в квадрат и выводит на экран монитора результат

1.Дано целое число N.Написать программу ,увеличивающую число в 3 раза ,если оно больше нуля

2.Дано целое число N.Написать программу ,заменяющую его нулём ,если больше или равно нулю,и увеличивающая его в 2 раза ,если число меньше нуля.
3 .Дано целые числа a и b .Написать программу , которая выводит сначала большее число ,затем меньшее.
4.Даны числа a,b,c.Написать программу ,выводящую их в возрастающем порядке.
ПЛИЗ ПОМОГИТЕ

1.Дано целое число,лежащее в диапазоне 1-999.Вывести его строку-описание вида "четное двузначное число","нечетное трехзначное число" и т.д.

2.Даны 3 переменные вещественного типа:А,В,С.Если их значения упорядочены по возрастанию,то удвоить их.В противном случае заменить значение каждой переменной на противоположное.Вывести новые значения переменных А,В,С.
3. Даны 3 целых числа,одно из которых отлично от двух других,равных между собой. Определить порядковый номер числа,отличного от остальных.

Составить программы в Turbo Pascal. 1)Дано три точки A,B,C на числовой оси.Найти длинну отрезка AC и BC и их сумму. 2)Задано четыре целых числа

a,b,c,d.Выяснить произведение этих чисел больше 300? 3)Дано целое число ,если оно положительное,то прибавить к нему 1,а если отрицательное.то отнять от него 2.Вывести полученое число.



Вы находитесь на странице вопроса "Дано целое число N (&gt; 1). Вывести наименьшее целое K, при котором выполняется неравенство 3K &lt; N, и само значение 3K", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.