Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

найти среднее арифметическое всех чисел от 100 до 900. в цикле с параметром

5-9 класс

Margharitavakh 13 апр. 2013 г., 3:41:50 (11 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Vakutuzova
13 апр. 2013 г., 4:27:15 (11 лет назад)

 Язык программирования - Python3

 

 

 

 ------------------------------------------------

d = 0
a = 0
for x in range(100,901):
     d += x
     a += 1
average = d // a
print(average)

 

 

 

 

 

 

 

 

+ 0 -
Vipsheret
13 апр. 2013 г., 5:13:14 (11 лет назад)

на Pascal
program noname;

uses crt;
var
i,k,l:longint;
r:real;
begin
clrscr;
k:=0;
l:=0;
for i:=100 to 900 do begin
k:=k+i;
l:=l+1;
end;
r:=k/l;
writeln(r);
end.

Ответить

Другие вопросы из категории

1. Выполните перевод: а)10101112 =… б) 721310 в)10101,01012 = г)101000012 = е)125,3510

2. Известно, что алфавитом некоторой позиционной системы счисления являются следующие символы:

0, 1, #, $, ?, @

а) каково основание этой системы?

б) какое число следует за числом ## в данной системе счисления;

в) выпишите первые 10 чисел натурального ряда в этой системе счисления.

Читайте также

1)Составить программу нахождения суммы квадратов чисел от 25 до 125.

2) составить программу нахождения чисел от 10 до 99 сумма квадратов которых кратна 13 (mod=0)
3) найти сумму всех целых нечетных чисел меньших 100
4) найти сумму чисел в диапазоне от A до B кратных четырём. Числа А и В вводятся с клавы.
5) Найти все натуральный делители натурального числа n

1)Напишите программу, которая в последовательности натуральных чисел определяет количество всех чисел, кратных 3 и оканчивающихся на 4. Программа получает

на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность).

2)Найти среднее арифметическое всех целых чисел от a до 200 (значения a и b вводятся с клавиатуры; a>=200);

Даны два целых числа А и В (А < В) . Найти произведение всех целых чисел от А до В включительно.

Входные данные: ввести два целых числа А,В (1 <=А,В<=10).
Входные данные: вывести произведение всех целых чисел от А до В включительно.

1)найти сумму первых k последовательных нечетных чисел. написать программу в паскале. 2)вывести на экран натуральные нечетные числа от 5 до 55.тоже

паскаль 3)найти произведение последовательных натуральных чисел от n до m. написать программу паскаль. 4)найти сумму последовательных натуральных чисел от 10 до 15.тоже паскаль



Вы находитесь на странице вопроса "найти среднее арифметическое всех чисел от 100 до 900. в цикле с параметром", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.