Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

С клавиатуры вводится число N. Программа должна сложить N первых четных чисел

10-11 класс

Ivanbezgodov001 28 янв. 2016 г., 2:59:59 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
рийка
28 янв. 2016 г., 5:48:55 (8 лет назад)

var i,n,s,k:integer;
begin
readln(n);
for i:=1 to n do begin
s:=s+k;
k:=k+2;
end;
writeln(s);
end.

Ответить

Другие вопросы из категории

Помогите найти ошибку плиз

uses crt;
var a:array[1..30] of integer;
s,i,m,n: integer;
begin
clrscr;
for i:= 1 to 30 do
begin
a[i]:=round(random*90-40);
write(a[i]:5);
end;
m:=a[1]; n:=1;
for i:= 1 to 30 do
if a[i]<m then m:=a[i]; n:=i;
writeln('min=',a[n]);
writeln('n=',n);
s:=0;
for i:= 1 to 30 do
if a[i]<0 then s:=s+a[i];
writeln('s=',s);
readln
end.

тест по информатике подскажите

1)информатика это:
а)Гуманитарная наука
в)Прикладная наука
с)Общественная наука
2)Компьютер это
а)Электронное вычислительное устройство для обработке чисел
в)устройство для хранения информации любого вида
с) многофукциональное электронное устройство, которое может автоматические обработки информации
б)устройство для обработки аналогия сигналов
3)минимальное необходимый набор аппаратных средств ПК состоит из
а)Винчестера,мыши,процессора
в)монитор,системный блок,клавиатура
с)принтер,клавиатуры,дисковод, сканер
4)устройство предназначенное для обработки информации
а)клавиатура
в)монитор
с)процессор
б)принтер
5)устройство предназначенное для обработки информации называется
а) внешния память
в)процессор
с)монитор
б)клавиатура

Читайте также

Всем привет, помогите написать программу в паскале, смысл прост. Программа должна переводить число из шестнадцатиричной системы счисления в дестяричную и

наоборот, тоесть после вводе числа- FFF программа должна вывести число 4095 и ниже снова FFF, программа должна быть простая и не слишком умная. Заранее спасибо

Требовалось написать программу,при выполнении которой с клавиатуры вводится натуральное число,не превосходящее 10^8, и выводится его первая цифра.Ученик

написал такую программу:
var n:longint;
begin
read(n);
while n>10 do
begin
n:=n mod 10
end;
write(n);
end.


1)Напишите,что выведет эта программа при вводе числа 1984.
2)Приведите пример числа,при вводе которого программа выдаст верный ответ.
3)Найдите в программе все ошибки.

Напишите программу, которая в последовательности целых чисел определяет их количество и подсчитывает сумму положительных чётных чисел, не превосходящих

256. Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа по модулю не превышают 30 000. Программа должна вывести два числа: длину последовательности и сумму положительных чётных чисел, не превосходящих 256.

1.Напишите программу, которая в последовательности натуральных чисел

определяет количество чисел, кратных 4. Программа получает на вход
количество чисел в последовательности, а затем сами числа. В
последовательности всегда имеется число, кратное 4. Количество чисел не
превышает 1000. Введённые числа не превышают 30 000. Программа должна
вывести одно число — количество чисел, кратных 4.

2. Напишите программу, которая в последовательности натуральных чисел определяет минимальное число, кратное 3. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 3. Количество чисел не превышает 1000. Введённые числа не превыша ют 30 000. Программа должна вывести одно число — минимальное число, кратное 3.



Вы находитесь на странице вопроса "С клавиатуры вводится число N. Программа должна сложить N первых четных чисел", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.