Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

Составьте программу, которая: а) из слова «ИНСТРУМЕНТЫ» составляет слова: «СТРУНЫ», «ТРУС», «ТУРИСТ»; б) из слов «ШИШКА», «ФЛАГ», «ТРОС» получает слово

10-11 класс

«ШРИФТ»; в) считает, сколько раз в тексте, заданном с клавиатуры, встречается буква «М».

Lola555649 16 авг. 2016 г., 1:04:54 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Умняшкинина
16 авг. 2016 г., 1:49:45 (7 лет назад)

var a:string;
begin
readln(a);
writeln(a[3],a[4],a[5],a[6],a[9],a[11]);
writeln(a[4],a[5],a[6],a[3]);
writeln(a[4],a[6],a[5],a[1],a[3],a[4]);
end.  

 

var a,b,c:string;
begin
readln(a,b,c);
writeln(a[1],c[2],a[2],b[1],c[1]);
end.  

 

var a:string; i:integer;
begin
readln(a);
while pos('М',a)<>0 do begin
inc(i);
delete(a,pos('М',a),1);
end;
writeln(i);
end.

+ 0 -
Ляляляч
16 авг. 2016 г., 3:10:56 (7 лет назад)

странное задание, но все же:

#include <string>
#include <vector>
#include <iostream>

bool compose( std::vector<std::wstring> &input, std::wstring result )
{
    for( int i = 0; i < result.size(); ++i ) {
        bool found( false );
        for( int j = 0; j < input.size(); ++j ) {
            if( input[j].find( result[i] ) != -1 ) {
                found = true;
                input[j].erase( input[j].begin() + input[j].find( result[i] ) );
            }
        }
        if( found == false )
            return false;
    }

    std::wcout << L"----\n";
    for( int i = 0; i < input.size(); ++i )
    {
        std::wcout << input[i] << L"\n";
    }
    std::wcout << L"----\n";
    std::wcout << result << L"\n";
    std::wcout << L"----\n";
    return true;
}

int main(int argc, wchar_t* argv[])
{
    std::vector<std::wstring> v1;
    v1.push_back( L"ИНСТРУМЕНТЫ" );
    compose( v1, L"СТРУНЫ" );

    std::vector<std::wstring> v2;
    v2.push_back( L"ИНСТРУМЕНТЫ" );
    compose( v2, L"ТРУС" );

    std::vector<std::wstring> v3;
    v3.push_back( L"ИНСТРУМЕНТЫ" );
    compose( v3, L"ТУРИСТ" );

    std::vector<std::wstring> v4;
    v4.push_back( L"ШИШКА" );
    v4.push_back( L"ФЛАГ" );
    v4.push_back( L"ТРОС" );
    compose( v4, L"ШРИФТ" );

    std::wstring text;
    std::wcout << L"\nТекст:";
    std::wcin >> text;
    int count = 0;
    for( int i = 0; i < text.size(); ++i ) {
        if( text[i] == L'M' )
            ++count;
    }
    std::wcout << L"\nколичество M: " << count;

    return 0;
}

Ответить

Другие вопросы из категории

В массиве хранятся сведения о количестве осадков, выпавших за 10 дней июня. Написать программу, которая определяет общее количество осадков за 10 дней.

Массив должен вводиться во время работы программы. Ниже представлен рекомендуемый вид экрана во время работы программы:

Введите в одной строке элементы массива (10 чисел) и нажмите <Enter>

-> 12 0 10 22 0 0 0 10 0 0

Общее количество осадков за 10 дней: 54

составить алгоритм и программу для следующих задач: 1)Вычислить процент материала, ушедщего в отходы, если из куба с ребром A был выточен шар радиуса R

(R< a) 2) Вычислить площадь кольца, ширина которого равна А, а отношение радиусов окружностей равно В .

Дан двумерный массив размером n*n. Создать функцию которая находит факториал каждого элемента массива и заменяет исходный элемент на его

факториал(значение функции). в первой строке написано число n.(4! =1*2*3*4)
3 2 24 5047
2 4 7 6 720 40320
3 6 8 2 24 120
2 4 5

Читайте также

В бейсике

Составьте программу, которая:
1) Из слова «ИНСТРУМЕНТЫ» составляет слова «ТРУС», «СТРУНЫ»;
2) Из слов «ШИШКА», «ФЛАГ», «ТРОС» получает слово «ШРИФТ».

Напишите прог-у на паскале... ПЛИИИИИИИИИИЗ 1)даны действительные числа a1, b1, c1, a2, b2, c2. Составьте программу, которая находит координаты точки

пересечения прямых, описываемых уравнениями a1x+b1x=c1 и a2x+b2x=c2. Если прямые пересекаются или не существуют-выдать соответствующее сообщение. 2) даны действительные числа a1, b1, a2, b2. Составьте программу, которая определяет, какая из точек A(a1;b1) или B(a2;b2) лежит на прямой у=2х+1. Если такой точки нет-вывести соответсвующее сообщение.

1.Составить программу, которая увеличивает каждый элемент настоящей таблице х [1 .. 10] на 1. 2. составить программу, замены положительных

элементов настоящей таблице х [1 .. 10] на 0.

3.составить программу, замены отрицательного элементов настоящей таблице х [1 .. 10] на их квадрат.

4.составить прогрумму, которая увеличивает на 2 все элементы настоящей таблице х [1 .. 10], которые больше 10.

1)составьте программу вычисления суммы чисел в диапазоне от 45 до 115 45+....+115

2)Составьте программу которая выводит на экран числа кратные 2 и 13 в диапазоне от 2 до 150
3)Дано вещественное число А и целое число N(>0).Испульзуя один цикл вывести все целые степени числа А от 1 до N

------------------------ОПЕРАТОР WHILE



Вы находитесь на странице вопроса "Составьте программу, которая: а) из слова «ИНСТРУМЕНТЫ» составляет слова: «СТРУНЫ», «ТРУС», «ТУРИСТ»; б) из слов «ШИШКА», «ФЛАГ», «ТРОС» получает слово", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.